Udostępnij za pośrednictwem


A known good App-V virtual application package may fail with error 19-00001003 after adding a pre-launch script

hotfixHere’s a great new KB article we published today.  If you’re seeing errors after adding a pre-launch script to one of your App-V packages then you’ll want to check this one out:

=====

Symptoms

A known good Microsoft Application Virtualization (App-V) package may fail with the following error after adding a pre-launch script:
Application Virtualization ErrorThe Application Virtualization Client could not launch <Package Name>. The Application Virtualization Client encountered a problem while waiting for the application to be ready to interact with the user. Report the following error code to your System Administrator. Error code: 4505CD-1F702A19-00001003

Cause

This is typically caused by a timing issue between the App-V client and the Windows Message Pump due to the pre-launch script.

Resolution

To resolve this issue, change the <SUBSYSTEM VALUE="windows"/> XML tag in the .OSD file from windows to console. This change will need to be implemented in each OSD file in the package.

Example:

Change:

<VM VALUE="Win32">
<SUBSYSTEM VALUE="windows"/>
</VM>

To:

<VM VALUE="Win32">
<SUBSYSTEM VALUE="console"/>
</VM>

If you are deploying packages using a Application Virtualization Server you will need to initiate a DC refresh on the App-V client to update the OSD cache. Once complete this issue should be resolved. If using Configuration Manager 2007 or an MSI package to deploy App-V applications, the package will need to be updated using the sequencer and redeployed.

=====

To continue reading this article please see the link below:

2628029: A known good App-V virtual application package may fail with error 19-00001003 after adding a pre-launch script

J.C. Hornbeck | System Center Knowledge Engineer

App-V Team blog: https://blogs.technet.com/appv/
AVIcode Team blog: https://blogs.technet.com/b/avicode
ConfigMgr Support Team blog: https://blogs.technet.com/configurationmgr/
DPM Team blog: https://blogs.technet.com/dpm/
MED-V Team blog: https://blogs.technet.com/medv/
OOB Support Team blog: https://blogs.technet.com/oob/
Opalis Team blog: https://blogs.technet.com/opalis
Orchestrator Support Team blog: https://blogs.technet.com/b/orchestrator/
OpsMgr Support Team blog: https://blogs.technet.com/operationsmgr/
SCMDM Support Team blog: https://blogs.technet.com/mdm/
SCVMM Team blog: https://blogs.technet.com/scvmm
Server App-V Team blog: https://blogs.technet.com/b/serverappv
Service Manager Team blog: https://blogs.technet.com/b/servicemanager
System Center Essentials Team blog: https://blogs.technet.com/b/systemcenteressentials
WSUS Support Team blog: https://blogs.technet.com/sus/

clip_image001 clip_image002

Comments

  • Anonymous
    May 28, 2015
    How do you initiate a DC refresh on the App-V client to update the OSD cache? I'm not having any luck and this looks to be the solution to a big problem we are having.

    Cheers