Er wordt een fout weergegeven in een adreslijstsynchronisatierapport: Dit bedrijf heeft het aantal objecten overschreden dat kan worden gesynchroniseerd
In dit artikel wordt beschreven hoe u het quotum voor de Active Directory-adreslijstservice voor adreslijstsynchronisatie in een Office 365-, Azure- of Microsoft Intune-omgeving verhoogt.
Oorspronkelijke productversie: Cloud Services (webrollen/werkrollen), Microsoft Entra-id, Microsoft Intune, Azure Backup, Office 365-gebruikers- en domeinbeheer
Oorspronkelijk KB-nummer: 2812409
Symptomen
U ontvangt een e-mailbericht van MSOnlineServicesTeam@MicrosoftOnline.com
met het volgende foutbericht:
Fout 016: Synchronisatie is gestopt. Dit bedrijf heeft het aantal objecten dat kan worden gesynchroniseerd, overschreden. Neem contact op met de ondersteuning voor Microsoft Online Services.
Notitie
Dit artikel kan ook worden gebruikt als u alleen wilt aanvragen om het quotum voor adreslijstservices te verhogen voor het geval u van plan bent om meer dan het toegestane aantal objecten in een Microsoft-cloudservice te hebben, zoals Office 365, Azure of Microsoft Intune, en u geen Active Directory-synchronisatie gebruikt. Het huidige quotum voor de adreslijstservice in Microsoft Entra-id is 50.000 objecten.
Oorzaak
Dit probleem treedt op omdat het aantal objecten dat u hebt gemaakt in uw Microsoft Entra-id de limiet voor de adreslijstservice overschrijdt. Elke organisatie kan slechts een beperkt aantal objecten maken in Microsoft Entra ID. Groepen, contactpersonen en gebruikersobjecten in uw Microsoft Entra-organisatie worden geteld als onderdeel van het adreslijstgebruik van uw organisatie.
Uw standaardquotum voor de adreslijstservice wordt berekend volgens de volgende richtlijnen:
Als u geen geverifieerde domeinen hebt, is het huidige quotum voor de adreslijstservice in Microsoft Entra-id 50.000 objecten.
- Als uw organisatie vóór 5 oktober 2011 is gemaakt, is uw standaardquotum voor de adreslijstservice 10.000 objecten.
- Als uw organisatie is gemaakt na 5 oktober 2011 en vóór mei 2012, is uw standaardquotum voor adreslijstservice 20.000 objecten.
- Als uw organisatie na mei 2012 is gemaakt, is uw standaardquotum voor adreslijstservice 50.000 objecten.
Als u ten minste één geverifieerd domein hebt, is het standaardquotum voor de adreslijstservice in Microsoft Entra-id 300.000 objecten.
Oplossing
Wanneer het aantal groepen, contactpersonen en gebruikersobjecten in uw on-premises Active Directory het quotum voor de adreslijstservice overschrijdt, kunt u een verhoging van het quotum voor uw bedrijf aanvragen. Na deze verhoging van uw limiet kunt u meer objecten synchroniseren dan de huidige standaardlimiet voor adreslijstsynchronisatie.
Als u wilt doorgaan met het maken van objecten in uw organisatie, moet u een domein toevoegen of een verhoging van het quotum voor de adreslijstservice aanvragen. Gebruik hiervoor de volgende methoden.
Methode 1
Als u geen geverifieerd domein hebt, moet u een domein toevoegen om uw quotumlimiet te verhogen naar 300.000 objecten. Zie Uw domein toevoegen voor meer informatie.
Methode 2
Als u meer dan 300.000 objecten in uw on-premises Active Directory-adreslijstservice hebt, neemt u contact op met Microsoft Ondersteuning om het aantal objecten te verhogen dat meer dan 300.000 kan worden gesynchroniseerd.
Meer informatie
Er wordt een quotum voor de adreslijstservice geïmplementeerd met de cloudservice als methode om een limiet in te stellen voor het maximum aantal objecten dat kan worden gemaakt door en in eigendom kan zijn van één beveiligingsprincipal. Voor alle objecten die worden gesynchroniseerd met adreslijstsynchronisatie van een bedrijf, wordt de waarde maker/eigenaar ingesteld op de standaardgroep beheerders voor dat bedrijf. De beheerdersgroep is bijvoorbeeld als volgt ingesteld: admins@contoso1.microsoftonline.com
Met deze configuratie wordt voorkomen dat gebruikers een onbeperkt aantal objecten kunnen maken met behulp van adreslijstsynchronisatie. Als uw bedrijf een legitieme reden heeft voor een verhoging van de limiet voor het aantal te synchroniseren objecten in de adreslijstservice, dient u een serviceaanvraag in bij de technische ondersteuning.
Veelgestelde vragen
Vraag 1: Tellen objecten die handmatig zijn toegevoegd via de cloudserviceportal of via de cloudservice-API, zoals Exchange Online PowerShell, mee op basis van het quotum van mijn onlinebedrijf?
Antwoord 1: Ja.
Vraag 2: Tellen verwijderde objecten mee voor mijn onlinebedrijfsquotum?
Antwoord 2: Ja. Wanneer een cloudserviceklant een object uit een onlinebedrijf verwijdert, wordt het verwijderde object in een container met verwijderde objecten in de adreslijstservice geplaatst. Het object blijft aanwezig in de container met verwijderde objecten tot de tombstonelevensduur is verstreken. De verlooptijd is momenteel ingesteld op 30 dagen.
Bekijk bijvoorbeeld het volgende scenario. Een onlinebedrijf evalueert een cloudservice door gebruik te maken van een on-premises niet-productieomgeving van Active Directory. De cloudserviceorganisatie is gemaakt vóór 5 oktober 2011 en de standaardsynchronisatielimiet is 10.000 objecten. Het bedrijf voert een bulksgewijze synchronisatie uit van 8.000 groeps- en contactpersoonsobjecten met behulp van het hulpprogramma Directory Sync. Later besluit het onlinebedrijf:
- Verwijder deze groepsobjecten en neem contact op met objecten uit de on-premises Active Directory DS-omgeving van het bedrijf.
- Voeg 8000 gebruikersobjecten toe aan de on-premises niet-productie Active Directory DS-omgeving.
- Synchroniseer de updates naar het onlinebedrijf.
De 8.000-groeps- en contactpersoonsobjecten worden verplaatst naar de container met verwijderde objecten in de adreslijstservice. Deze objecten vormen tot wel 25 procent van het onlinebedrijsquotum totdat ze permanent worden verwijderd na de tombstoneperiode van 30 dagen. (Dit percentage is gelijk aan 2.000 objecten of 8.000 × 25 procent.) Na het synchroniseren van de 5.000 nieuwe gebruikersobjecten, verbruikt het onlinebedrijf 10.000 objecten van het beschikbare Active Directory-quotum, bestaande uit 2.000 verwijderde objecten plus 8.000 nieuwe gebruikersobjecten. Tijdens de tombstoneperiode van 30 dagen (en deze periode kan samenvallen met de evaluatieperiode van het onlinebedrijf) kan het onlinebedrijf mogelijk geen objecten meer toevoegen met behulp van adreslijstsynchronisatie. Dit komt doordat de adreslijstservicelimiet van het onlinebedrijf is bereikt.
In dit scenario moet het onlinebedrijf dat de evaluatie van de Cloudservice uitvoert, het aantal objecten in de on-premises niet-productieomgeving van Active Directory Domain Services verminderen om de productevaluatie te voltooien. Als het onlinebedrijf het aantal objecten niet kan verminderen, moet het bedrijf een hoger quotum voor de adreslijstservice aanvragen.
Vraag 3: Betekent het hebben van meer dan één geverifieerd domein dat ik een quotum kan hebben dat hoger is dan 300.000 objecten?
Antwoord 3: Nee. U hebt een adreslijstquotum van 300.000 objecten als u een of meer geverifieerde domeinen hebt. U krijgt geen quotum van 300.000 objecten voor elk geverifieerd domein dat u registreert.
Contacteer ons voor hulp
Als u vragen hebt of hulp nodig hebt, maak een ondersteuningsaanvraag of vraag de Azure-communityondersteuning. U kunt ook productfeedback verzenden naar de Azure-feedbackcommunity.