Delen via


Fout AADSTS7000112 - Toepassing is uitgeschakeld

In dit artikel wordt beschreven hoe u de AADSTS7000112 fout kunt oplossen die optreedt wanneer u zich probeert aan te melden bij een toepassing die samen met Microsoft Entra-id kan worden gebruikt.

Symptomen

Wanneer u zich probeert aan te melden bij een Azure-toepassing die is geïntegreerd in Microsoft Entra ID, ontvangt u het volgende AADSTS7000112 foutbericht:

Toepassing '<appIdentifier>' (<appName>) uitgeschakeld.

Oorzaak

Het service-principal-object is uitgeschakeld voor de resourcetenant.

Oplossing

Werk samen met de eigenaren van de resourcetenant om te bepalen waarom het service-principal-object is uitgeschakeld. Gebruik vervolgens de volgende tabel om de juiste actie te ondernemen.

Scenario Actie
De service-principal moet worden uitgeschakeld. Doe niets. Toegang is opzettelijk geblokkeerd. We verwachten of raden niet aan dat resourcetenantbeheerders van toepassingen van de eerste partij de respectieve service-principal uitschakelen. Microsoft Services richt de service-principals automatisch in en beheert deze.
De service-principal moet niet worden uitgeschakeld of is per ongeluk uitgeschakeld. Vraag de eigenaren van de resourcetenant om de service-principal opnieuw in te schakelen. Een methode om de service-principal opnieuw in te schakelen, is door PowerShell te gebruiken om de -AccountEnabled parameter in te stellen op $true. Zie de naslaginformatie over de set-AzureADServicePrincipal-cmdlet voor meer informatie.

Meer informatie

Zie Microsoft Entra-verificatie- en autorisatiefoutcodes voor een volledige lijst met verificatie- en autorisatiefoutcodes.

Als u afzonderlijke fouten wilt onderzoeken, gaat u naar https://login.microsoftonline.com/error.

Contacteer ons voor hulp

Als u vragen hebt of hulp nodig hebt, maak een ondersteuningsaanvraag of vraag de Azure-communityondersteuning. U kunt ook productfeedback verzenden naar de Azure-feedbackcommunity.