Delen via


Het importeren van de oplossing mislukt vanwege ontbrekende onderdelen

Dit artikel bevat een oplossing voor de fout bij het importeren van de oplossing [oplossingsnaam] die kan optreden wanneer u probeert een oplossing te importeren in Microsoft Dynamics 365.

Van toepassing op: Microsoft Dynamics 365
Origineel KB-nummer: 4346030

Symptomen

Wanneer u probeert een oplossing te importeren in Microsoft Dynamics 365, mislukt het importeren met het volgende bericht:

Het importeren van de oplossing [naam oplossing] is mislukt. De volgende onderdelen ontbreken in uw systeem en zijn niet opgenomen in de oplossing. Importeer de beheerde oplossingen die deze onderdelen bevatten ([naam van ontbrekende oplossing] ([oplossingsversie])) en probeer de oplossing opnieuw te importeren.

Mogelijk ziet u ook een verwijzing naar foutcode 8004801d.

Oorzaak

Deze fout treedt op als u probeert een oplossing te importeren die afhankelijk is van andere onderdelen die zich niet in uw Microsoft Dynamics 365 organisatie bevinden.

Voorbeeld: U hebt een ontwikkelomgeving waarin u een oplossing (oplossing A) hebt gemaakt die een aangepaste entiteit (Widget) bevat. U hebt een andere oplossing (oplossing B) gemaakt die afhankelijk is van een onderdeel in oplossing A (bijvoorbeeld een nieuw veld toegevoegd aan de entiteit Widget). Als u probeert oplossing B te importeren in een andere organisatie (bijvoorbeeld uw productieorganisatie) waarop oplossing A nog niet is geïnstalleerd, treedt deze fout op.

Oplossing

Controleer de ontbrekende onderdeeldetails die worden weergegeven in het importdialoogvenster. Als er andere oplossingen worden vermeld die nog niet zijn geïmporteerd in de organisatie waarin u deze oplossing probeert te importeren, importeert u deze oplossingen eerst voordat u deze oplossing probeert te importeren.

Voorbeeld: Als u verdergaat met het voorbeeld uit de sectie Oorzaak hierboven, ziet u mogelijk dat in de lijst met ontbrekende onderdelen een of meer rijen worden weergegeven waarin de kolom Beheerde oplossing verwijst naar oplossing A. Dit geeft aan dat u de genoemde versie van oplossing A moet importeren voordat u oplossing B kunt importeren.

Meer informatie

Als het foutbericht verwijst naar een Microsoft-oplossing, raadpleegt u de volgende lijst met oplossingen en waar ze kunnen worden gevonden als ze niet zijn geïnstalleerd in de doelorganisatie:

LinkedIn Sales Navigator voor Dynamics 365

Oplossingsnamen:

  • LinkedInSalesNavigatorControlsForUnifiedClient

  • LinkedIn

  • msdyn_LinkedInSalesNavigatorAnchor

    Opmerking

    Als u deze oplossingen wilt verwijderen, moeten ze worden verwijderd in de volgorde van de bovenstaande lijst.