Delen via


Fout bij het upgraden van de MARS-agent: de update van de Microsoft Azure Recovery Services-agent is mislukt

In dit artikel worden de symptomen en oplossing beschreven voor een probleem dat optreedt wanneer u probeert een upgrade uit te voeren van een oudere versie naar een nieuwere versie of versie van de MARS-agent (Microsoft Azure Recovery Services).

Oorspronkelijke productversie: Azure Site Recovery
Oorspronkelijk KB-nummer: 4020490

Symptomen

Wanneer u de MARS-agent probeert bij te werken met behulp van de upgradewizard van de Microsoft Azure Recovery Services-agent, mislukt de upgrade en ontvangt u het volgende foutbericht:

De update van de Microsoft Azure Recovery Service-agent is mislukt.
Fout: Kan de RecoveryServicesManagementAgent-service niet starten. De patch verwijderen
Probleem: De installatie bijwerken is mislukt met fout 1612

Oorzaak

Dit probleem treedt op omdat de upgrade het broninstallatieprogramma voor de MARS-agent niet kan vinden in de Windows Installer-cache. Het broninstallatieprogramma is vereist om de upgrade te voltooien.

Oplossing

U kunt dit probleem oplossen door ervoor te zorgen dat het broninstallatieprogramma bestaat in de Windows Installer-cache. Hiervoor volgt u deze stappen:

  1. Sluit de upgradewizard van de Microsoft Azure Recovery Services-agent af.

  2. Open het OBPatch.log bestand dat zich in de C:\Windows\Temp map bevindt.

  3. Zoek de foutbeschrijvingsregel in het OBPatch.log-bestand naar 'Waarschuwing: lokaal in cache geplaatst pakket'.

  4. Zoek een regel die lijkt op het volgende: Waarschuwing:

    Lokaal in cache opgeslagen pakket 'C:\Windows\Installer\Unique_ID.msi ontbreekt.

  5. Noteer theUnique_IDvalue voor toekomstige naslaginformatie.

  6. Dubbelklik op het installatieprogramma van de MARS-agent (.exe). Hiermee worden alle binaire bestanden en installatiebestanden gekopieerd naar een tijdelijke locatie op uw computer en wordt de wizard Upgrade van de Microsoft Azure Recovery Services-agent geopend.

    Opmerking Laat de wizard geopend tot stap 12.

  7. Open het bestand OBInstaller0Curr.errlog dat zich in de map C:\Windows\Temp bevindt.

  8. Zoek in de tekst naar 'Mappad voor SetupLaunchScreen' en zoek vervolgens de regel met het laatste tijdstempel dat er ongeveer als volgt uitziet: Mappad voor SetupLaunchScreen: C:\Temp_ID.

  9. Ga naar de map C:\Temp_ID\Installers.

  10. Zoek en kopieer in deze map het OBSAGENT.msi bestand naar de map C:\Windows\Installer. Wijzig de naam van het doelbestand als Unique_ID.msi.

  11. Sluit de upgradewizard van de MARS-agent.

  12. Voer het upgrade-installatieprogramma uit om de upgrade te installeren. Als het probleem zich blijft voordoen, neemt u contact op met Microsoft Ondersteuning.

Contacteer ons voor hulp

Als u vragen hebt of hulp nodig hebt, maak een ondersteuningsaanvraag of vraag de Azure-communityondersteuning. U kunt ook productfeedback verzenden naar de Azure-feedbackcommunity.