Delen via


Back-up van microsoft Azure Recovery Services-agent (fout-id 8007007B)

In dit artikel worden de symptomen en oplossing beschreven voor een fout die optreedt wanneer u een back-up maakt van de systeemstatus met behulp van de Mars-agent (Microsoft Azure Recovery Services).

Oorspronkelijke productversie: Azure Backup
Oorspronkelijk KB-nummer: 4053355

Symptomen

Een van de volgende foutberichten wordt weergegeven op het tabblad Fouten van het dialoogvenster Taakdetails die overeenkomt met een mislukte back-uptaak van de systeemstatus in de Microsoft Azure Recovery Services Agent-console.

Kan de bewerking niet uitvoeren omdat de Back-uptaak van Windows Server is mislukt met het foutbericht: Er is geen back-up gemaakt van de items die zijn opgenomen in de back-up. Gedetailleerde fout: de syntaxis van de bestandsnaam, mapnaam of volumelabel is onjuist HResult: 80780049 DetailedHResult: 8007007B Goto https://go.microsoft.com/fwlink/?linkid=847810 om dit op te lossen. (0x1873D)

Er kan met Windows Server geen back-up worden gemaakt van de systeemstatus omdat door een systeemschrijver een ongeldig pad is gemeld. Foutbericht windows Server Backup: De syntaxis van de bestandsnaam, mapnaam of volumelabel is onjuist HResult: 80780049 DetailedHResult: 8007007B Goto https://go.microsoft.com/fwlink/?linkid=859092 om dit op te lossen. (0x18770)

Schermopname van de mislukte taakfout voor back-up van de systeemstatus.

Wanneer u op WSB-foutenlogboeken klikt, wordt een bestand geopend dat een foutbericht bevat dat er ongeveer als volgt uitziet:

Fout in back-up van Systemroot_pathduring opsomming: Fout [0x8007007b] De syntaxis van de bestandsnaam, mapnaam of volumelabel is onjuist.

Oorzaak

Deze fout treedt op wanneer de bestandsspecificatie die is vereist voor het inventariseren van bestanden waarvan een back-up moet worden gemaakt als onderdeel van de Windows Server-systeemstatus onjuist wordt bijgewerkt.

Oplossing

Waarschuwing

Er kunnen zich ernstige problemen voordoen als u het register met de Register-editor of met een andere methode foutief wijzigt. Wellicht moet u door deze problemen het besturingssysteem opnieuw installeren. Microsoft kan niet garanderen dat deze problemen kunnen worden opgelost. Het wijzigen van het register is voor eigen risico.

Volg deze stappen om ervoor te zorgen dat de bestandsspecificatie is bijgewerkt:

  1. Controleer in het bestand dat wordt geopend wanneer u op WSB-foutenlogboeken klikt of de Systemroot_path juist is. Systemroot_path in het volgende foutbericht ziet er bijvoorbeeld als volgt uitC:\Windows\\systemroot\:

    Fout in back-up van c:\windows\systemroot\ tijdens het inventariseren: Fout [0x8007007b] De syntaxis van de bestandsnaam, mapnaam of volumelabel is onjuist.

  2. Voer vanaf een opdrachtprompt met verhoogde bevoegdheid de volgende opdracht uit:

    diskshadow /l Output_File_Path
    

    Notitie

    De tijdelijke aanduiding Output_File_Path moet eruitzien C:\outputfilepath.txt.

  3. Typ de volgende opdrachten bij een DISKSHADOW-prompt en druk op Enter na elke opdracht:

    list writers detailed
    
    exit  
    
  4. Open het uitvoerbestand dat u hebt opgegeven in stap 2.

  5. Zoek de regel met Systemroot_path (C:\Windows\\systemroot\ in het bovenstaande voorbeeld). De regel moet bijvoorbeeld lijken op het volgende: Bestandslijst: Pad = Systemroot_path\system32\drivers, Filespec = File_Spec_Path

    Bijvoorbeeld:

    Bestandslijst: Pad = C:\windows\\systemroot\system32\drivers, Filespec = winmad.sys

  6. Start de Register-editor. Klik hiervoor met de rechtermuisknop op Start, klik op Uitvoeren, typ regedit in het vak Openen en klik vervolgens op OK.

  7. Zoek de volgende subsleutel: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services

  8. Klik met de rechtermuisknop op Services en klik vervolgens op Zoeken.

    Schermopname van de optie Zoeken onder services in de Register-editor.

  9. Typ in het vak Zoeken naar het pad File_Spec_Path dat u in stap 5 hebt gevonden en klik vervolgens op Volgende zoeken.

    Schermopname van het File_Spec_Path pad in het vak Zoeken.

    Voorbeeld:

    Schermopname van het voorbeeld in het vak Zoeken naar welk vak.

    De zoekresultaten bevatten een registersleutel met de naam ImagePath. Als de waarde een voorloopbackslash '' heeft, dubbelklikt u op die waarde en verwijdert u deze. Als de waarde niet begint met een backslash, dient u een ondersteuningsaanvraag in vanuit Azure Portal.

    Voordat u het wijzigt Na wijziging
    Schermopname van de zoekresultaten voor het afbeeldingspad voordat deze wordt gewijzigd.
    Schermopname van de zoekresultaten voor het afbeeldingspad na wijziging.
  10. Ga terug naar de MARS Agent-console en start een systeemstatusback-up door op Nu back-up maken te klikken.

Contacteer ons voor hulp

Als u vragen hebt of hulp nodig hebt, maak een ondersteuningsaanvraag of vraag de Azure-communityondersteuning. U kunt ook productfeedback verzenden naar de Azure-feedbackcommunity.