HPC-taken blijven hangen in de annuleringsmodus en nieuwe taken worden niet gestart
Dit artikel bevat een oplossing voor problemen met het uitvoeren van taken die vastzitten in de modus Annuleren en nieuwe taken kunnen niet worden omgezet in de actieve status wanneer een Azure SQL-database wordt gebruikt voor een externe HPC PACK-database.
Symptomen
Wanneer u de actieve taken annuleert, blijven ze hangen in de modus Annuleren en worden er nog steeds nieuwe taken in de wachtrij geplaatst terwijl er rekenknooppunten beschikbaar zijn om de taken uit te voeren. Het opnieuw opstarten van de knooppunten helpt niet.
Ondertussen bereikt de PaaS-database (Platform as a Service) 100%, en ziet u het volgende foutbericht in het HPC Scheduler-logboek:
De scheduler-server is bezet. De clientaanvraag kan nu niet worden verwerkt. Probeert u het later nog eens.
Oorzaak
Dit probleem treedt op omdat het hoofdknooppunt overbelast is omdat de PaaS-database de prestatielimiet bereikt.
Oplossing
Als u dit probleem wilt oplossen, verhoogt u de Database Transaction Unit (DTU) naar een hogere SKU voor de scheduler-database in Azure die overeenkomt met uw workload. De minimale initiƫle DTU die is vereist voor de HPC Scheduler-database is 100 DTU.
Verwijzingen
Zie stap 1 voor meer informatie: De externe databases voorbereiden.
Contacteer ons voor hulp
Als u vragen hebt of hulp nodig hebt, maak een ondersteuningsaanvraag of vraag de Azure-communityondersteuning. U kunt ook productfeedback verzenden naar de Azure-feedbackcommunity.