Er is geen ruimte beschikbaar op station E of F
In dit artikel wordt beschreven hoe u een scenario kunt oplossen waarin station E of F in Microsoft Azure Cloud Services onvoldoende vrije ruimte heeft.
Symptomen
U host een exemplaar van Cloud Services, maar u ontdekt dat uw station E of F geen vrije ruimte heeft.
Oorzaak
Omdat stations E en F worden gebruikt als het schijfstation van de toepassing, moeten er geen toepassingsgerelateerde gegevens worden opgeslagen op deze stations. Gegevensopslag kan ertoe leiden dat het ruimtegebruik veel groter is dan de som van de afzonderlijke bestandsgrootten. Zie Waar is mijn ruimte gebleven? voor meer informatie.
De gebruikte opslagruimte mag geen invloed hebben op de werking van de toepassing. Nadat de stations zijn gemaakt, schrijven virtuele Azure-machines er niet naar, tenzij de toepassingscode dat doet. De toepassingscode mag in ieder geval niet naar deze stations schrijven.
Oplossing
Voor gegevens waarnaar een toepassing moet lezen en schrijven, raden we u aan een externe opslagservice te gebruiken, zoals Azure Storage of Azure SQL Server.
Als de locatie van het lokale gegevensarchief nodig is, moet u ervoor zorgen dat de toepassingscode gebruikmaakt van lokale opslagbronnen. Deze worden opgeslagen op het lokale station C. Zie Lokale opslagresources en Azure-schijfpartities configureren voor meer informatie.
Disclaimerinformatie van derden
De producten van derden die in dit artikel worden vermeld, worden vervaardigd door bedrijven die onafhankelijk zijn van Microsoft. Microsoft verleent dan ook geen enkele garantie, impliciet noch anderszins, omtrent de prestaties of de betrouwbaarheid van deze producten.
Contacteer ons voor hulp
Als u vragen hebt of hulp nodig hebt, maak een ondersteuningsaanvraag of vraag de Azure-communityondersteuning. U kunt ook productfeedback verzenden naar de Azure-feedbackcommunity.