Problemen met de foutcode TooManyRequestsReceived of SubscriptionRequestsThrottled oplossen
In dit artikel wordt beschreven hoe u de TooManyRequestsReceived
of SubscriptionRequestsThrottled
fout kunt identificeren en oplossen die optreden wanneer u probeert een AKS-cluster (Microsoft Azure Kubernetes Service) te verwijderen.
Symptomen
Wanneer u probeert een AKS-cluster te verwijderen, wordt het volgende foutbericht weergegeven:
internalErrorCode: TooManyRequestsReceived
StatusCode: 429
{
bericht: 'Aantal leesaanvragen voor abonnement '.....'' heeft de limiet van '....' overschreden voor tijdsinterval 'XX:XX:XX'. Probeer het opnieuw na '.....' seconden.
}
Oorzaak
Elke bewerking op abonnementsniveau en tenantniveau is onderhevig aan beperkingslimieten. Deze limieten zijn van toepassing op elk exemplaar van Azure Resource Manager. Wanneer u de limiet bereikt, ontvangt u een HTTP-antwoord dat statuscode 429 aangeeft: 'Te veel aanvragen'.
Oplossing
Het HTTP-antwoord bevat een Retry-After
waarde. Hiermee geeft u het aantal seconden op dat uw toepassing moet wachten (of in de slaapstand) moet staan voordat de volgende aanvraag wordt verzonden. Als u een aanvraag verzendt voordat de waarde voor opnieuw proberen is verstreken, wordt uw aanvraag niet verwerkt en wordt een nieuwe waarde voor opnieuw proberen geretourneerd. Zie Resource Manager-aanvragen beperken voor meer informatie over beperkingslimieten.
Contacteer ons voor hulp
Als u vragen hebt of hulp nodig hebt, maak een ondersteuningsaanvraag of vraag de Azure-communityondersteuning. U kunt ook productfeedback verzenden naar de Azure-feedbackcommunity.