Problemen met de foutcode SubscriptionRequestsThrottled (429) oplossen
In dit artikel wordt beschreven hoe u de SubscriptionRequestsThrottled
fout (status 429) identificeert en oplost die optreedt wanneer u probeert een AKS-cluster (Microsoft Azure Kubernetes Service) te maken en te implementeren.
Symptomen
Wanneer u probeert een AKS-cluster te maken, wordt het volgende foutbericht 'Standaard load balancer afstemmen mislukt' weergegeven met de waarde 'SubCode' van SubscriptionRequestsThrottled en de waarde Status van 429:
Het afstemmen van de standard load balancer is mislukt.
Details: het opnieuw proberen van uitgaandeReconciler is mislukt:
Categorie: ClientError;
SubCode: SubscriptionRequestsThrottled;
Afhankelijkheid: Microsoft.Network/PublicIPAddresses;
OrginalError: autorest/azure: Service heeft een fout geretourneerd. Status=429
Code="SubscriptionRequestsThrottled"
Message="Number of requests for subscription-id-guid><" and operation 'GET/SUBSCRIPTIONS/RESOURCEGROUPS/PROVIDERS/MICROSOFT. NETWORK/PUBLICIPADDRESSES' heeft de limiet voor back-endopslag overschreden. Probeer het opnieuw na '6' seconden.'
AKSTeam: Netwerken, ophaalbaar: false.
Aanvraagbeperking kan optreden op verschillende Azure-onderdelen, dus het foutbericht kan afwijken op basis van het type resource waarop dit probleem zich voordoet.
Oorzaak
Azure Resource Manager-aanvragen worden beperkt. Zie Resource Manager-aanvragen beperken voor informatie over de werking van Azure Resource Manager-limieten en de specifieke limieten per uur.
Oplossing 1: Een ander abonnement gebruiken
Als u toegang hebt tot een ander abonnement, kunt u het cluster eenvoudig implementeren in dat abonnement.
Oplossing 2: Uw toegangspatronen wijzigen
U kunt dit probleem oplossen door uw toegangspatronen voor het beperkte abonnement te onderzoeken. De volgende tabel bevat de mogelijke toegangspatronen en bijbehorende oplossingen.
Toegangspatroon | Oplossing |
---|---|
Geautomatiseerde scripts scannen het abonnement voortdurend | De scripts minder vaak uitvoeren |
Veel gebruikers hebben toegang tot het abonnement | Laat elke gebruiker een eigen abonnement gebruiken |
Scripts scannen elk opslagaccount in het abonnement | Bereik het script om alleen een query uit te voeren op de resources die het moet hebben |
Meer informatie
Contacteer ons voor hulp
Als u vragen hebt of hulp nodig hebt, maak een ondersteuningsaanvraag of vraag de Azure-communityondersteuning. U kunt ook productfeedback verzenden naar de Azure-feedbackcommunity.