Fout AADSTS50011 met SAML-verificatie: de antwoord-URL die is opgegeven in de aanvraag komt niet overeen
Dit artikel bevat een oplossing voor de AADSTS50011 fout die optreedt tijdens federatieve verificatie met Microsoft Entra-id.
Symptomen
Er wordt een foutbericht AADSTS50011
weergegeven wanneer u zich probeert aan te melden bij een toepassing die is ingesteld voor het gebruik van Microsoft Entra ID voor identiteitsbeheer met eenmalige aanmelding op basis van SAML.
Fout AADSTS50011: de antwoord-URL komt niet overeen met de antwoord-URL's die zijn geconfigureerd voor de toepassings-GUID<>. Zorg ervoor dat de antwoord-URL die in de aanvraag wordt verzonden, overeenkomt met de antwoord-URL die is toegevoegd aan uw toepassing in Azure Portal. Ga naar https://aka.ms/urlMismatchError meer informatie over hoe u dit kunt oplossen. Wanneer u zich probeert aan te melden bij een op SAML gebaseerde eenmalige aanmelding (SSO) geconfigureerde app die is geïntegreerd met Microsoft Entra ID.
Oorzaak
De AssertionConsumerServiceURL
waarde in de SAML-aanvraag komt niet overeen met de waarde of het patroon antwoord-URL die is geconfigureerd in Microsoft Entra-id. De waarde AssertionConsumerServiceURL
in de SAML-aanvraag is de URL die u ziet in de fout.
Oplossing
Volg deze stappen om het probleem op te lossen:
- Zorg ervoor dat de
AssertionConsumerServiceURL
waarde in de SAML-aanvraag overeenkomt met de antwoord-URL-waarde die is geconfigureerd in Microsoft Entra-id. - Controleer de waarde in het tekstvak Antwoord-URL of werk dit zo bij dat deze overeenkomt met de
AssertionConsumerServiceURL
-waarde in de SAML-aanvraag.
Raadpleeg als voorbeeld het volgende artikel voor gedetailleerde stappen over het configureren van de waarden in Microsoft Entra-id:
Notitie
De antwoord-URL wordt ook wel omleidings-URI genoemd. Deze waarden zijn afhankelijk van de toepassing die wordt gebruikt. Als het goed is, krijgt u de waarden van de leverancier van de toepassing.
Nadat u de waarde van de antwoord-URL in Microsoft Entra-id hebt bijgewerkt en deze overeenkomt met de waarde die door de toepassing in de SAML-aanvraag is verzonden, moet u zich kunnen aanmelden bij de toepassing.
Meer informatie
Contacteer ons voor hulp
Als u vragen hebt of hulp nodig hebt, maak een ondersteuningsaanvraag of vraag de Azure-communityondersteuning. U kunt ook productfeedback verzenden naar de Azure-feedbackcommunity.