Delen via


Gebruikers die Outlook voor iOS- en Android- en ABQ-regels (Device Access) gebruiken, worden onverwacht in quarantaine geplaatst

Origineel KB-nummer: 3193518

Symptomen

Exchange Online gebruikers die Outlook voor iOS en Android gebruiken en die ook abq-regels (Device Access) gebruiken, merken dat ze onverwacht in quarantaine zijn geplaatst. Dit probleem treedt op in het volgende scenario:

  • De eigenschap van de DefaultAccessLevel tenant die is geconfigureerd via Set-ActiveSyncOrganizationSettings , is ingesteld op de waarde Quarantaine of Blokkeren.
  • De tenantbeheerder heeft Outlook voor iOS en Android eerder toegestaan door de DeviceID in de ActiveSyncAllowedDeviceIDs eigenschap van het postvak te stempelen.
  • De apparaten worden niet beheerd door Microsoft Intune.

Oorzaak

Een wijziging in het back-endprotocol in de wijze waarop microsoft 365-postvakgegevens worden geopend via Outlook voor iOS- en Android-toepassingen, wijzigt de DeviceID die de app gebruikt om verbinding te maken met Exchange Online. Het verwachte gedrag is dat de nieuwe DeviceID automatisch wordt toegevoegd aan de ActiveSyncAllowedDeviceID voor de gebruiker. Maar in bepaalde scenario's kan het apparaat in quarantaine worden geplaatst. In dergelijke gevallen volgt u de stappen in de sectie Oplossing. Dit probleem zal naar verwachting niet herhaaldelijk optreden.

Oplossing

Neem contact op met ondersteuning en vraag de medewerker van de klantenservice om u te helpen het apparaat te deblokkeren.

U kunt ook een van de volgende methoden gebruiken om het apparaat te deblokkeren:

  • Gebruik het Exchange-beheercentrum om de blokkering van afzonderlijke apparaten op te heffen. Ga hiervoor als volgt te werk:

    1. Meld u aan bij het Exchange-beheercentrum. Zie Exchange-beheercentrum in Exchange Online voor meer informatie.
    2. Selecteer Mobiel en selecteer vervolgens onder Apparaten in quarantaine de knop Toestaan voor elk Outlook voor iOS- en Android-app-apparaat dat moet worden gedeblokkeerd.
  • Gebruik externe PowerShell om alle apparaten te deblokkeren. Ga hiervoor als volgt te werk:

    1. Maak verbinding met Exchange Online via externe PowerShell. Raadpleeg Verbinding maken met Exchange Online PowerShell voor meer informatie.

    2. Kopieer en plak de volgende code in uw externe PowerShell-sessie:

      function FixUnblock { $Mbxs = Get-CASMailbox -ResultSize 10000 | ?{$_.ActiveSyncAllowedDeviceIDs -ne $null } foreach($Mbx in $Mbxs) { write-host $Mbx.Id $IdList = Get-MobileDevice -Mailbox $Mbx.Id | where {$_.DeviceModel -eq "Outlook for iOS and Android" -and $_.ClientType -eq "REST" -and $_.DeviceAccessState -ne "Allowed" -and $_.FirstSyncTime -ge "9/13/2016"} $CasDevice = Get-CasMailbox $Mbx.Id foreach( $Id in $IdList) { $CasDevice.ActiveSyncAllowedDeviceIDs += $Id.DeviceId } Set-CasMailbox $Mbx.Id -ActiveSyncAllowedDeviceIDs $CasDevice.ActiveSyncAllowedDeviceIDs } }
      
    3. Voer de functie uit in uw externe PowerShell-sessie. Hiervoor typt u FixUnblock en drukt u op Enter.

Meer informatie

Gebruikers met moderne verificatie-accounts moeten de stappen volgen in Account instellen met moderne verificatie in Exchange Online om hun Outlook voor iOS- en Android-account in te stellen.

Meer hulp nodig? Ga naar Microsoft Community.