403: Fout Verboden wanneer u informatie over beschikbaarheid in de hele organisatie probeert weer te geven in Exchange
Origineel KB-nummer: 3082946
Samenvatting
Wanneer u de beschikbaarheidsinfo voor de hele organisatie probeert weer te geven, mislukt de poging en wordt de fout 403: Verboden gegenereerd.
U hebt bijvoorbeeld Forest A op een server met Microsoft Exchange 2007 en Forest B op een server waarop Exchange Server 2013 of Exchange Server 2010 wordt uitgevoerd. In deze situatie kan een gebruiker in Forest A de beschikbaarheidsinfo van een gebruiker in Forest B niet zien. Daarnaast wordt de volgende gebeurtenis vastgelegd in het gebeurtenislogboek op de bronserver:
Log Name: Application
Source: MSExchange Availability
Date: Date
Event ID: 4002
Task Category: Availability Service
Level: Error
Keywords: Classic
User: N/A
Computer: <Computer Name>
Description:
Process <Process ID>[w3wp.exe:/LM/W3SVC/1/ROOT/EWS-1-130778800910201315]: Proxy request CrossForest from
Requester:S-1-5-21-1016748826-3068013645-1401187561-1105 to https://<ONLINE_URL>/EWS/Exchange.asmx failed.
Caller SIDs: . The exception returned is Microsoft.Exchange.InfoWorker.Common.Availability.ProxyWebRequestProcessingException:
System.Net.WebException: The request failed with HTTP status 403: Forbidden.
Op de doelserver wordt de volgende vermelding geregistreerd in het IIS-logboek (Internet Information Service), onder de map W3SVC1:
IIS Logs: 2015-06-08 04:19:25 <IP Address> POST /EWS/Exchange.asmx &CorrelationID=<empty>;&ClientId=JQJLGECZ0MGEHVVWEBZG&cafeReqId=9f422915-0721-48ce-b2c6-4406d2c1b49d; 443 domain\serviceaccount <IP Address> ASProxy/CrossForest/EmailDomain/EXCH/08.03.0083.000 - 403 0 0 718
Op de server waarop Exchange Server 2013 wordt uitgevoerd, wordt de volgende vermelding vastgelegd in het HTTPProxy-logboek:
WebExceptionStatus=ProtocolError;ResponseStatusCode=403;WebException=System.Net.WebException: The remote server returned an error: (403) Forbidden. at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult) at Microsoft.Exchange.HttpProxy.ProxyRequestHandler.<>c__DisplayClass2c.<OnResponseReady>b__2b();
Op de postvakserver wordt de volgende vermelding vastgelegd in het IIS-logboek, onder de map W3SVC2:
2015-06-08 04:16:29 <IP Address> POST /EWS/Exchange.asmx - 444 domain\serviceaccount 10.152.152.166 ASProxy/CrossForest/EmailDomain/EXCH/08.03.0083.000 403 0 0 233
Op de Postvakserver wordt de volgende vermelding vastgelegd in het EWS-logboek:
AuthError=User not allowed to access EWS;,FaultInnerException=Microsoft.Exchange.Services.Core.Types.ServiceAccessDeniedException: Access is denied. Check credentials and try again.;ExceptionHandlerBase_ProvideFault_FaultException=System.ServiceModel.FaultException: Access is denied. Check credentials and try again. at Microsoft.Exchange.Services.Wcf.MessageInspectorManager.InternalAfterReceiveRequest(Message& request IClientChann
Oorzaak
Dit probleem treedt op omdat EWS is geblokkeerd in Forest B op organisatieniveau. Forest B staat alleen geselecteerde toepassingen toegang tot EWS toe. EWS is niet toegestaan voor aanvragen voor beschikbaarheid in meerdere forests.
Voer de volgende opdracht uit om de organisatieconfiguratie te controleren:
Get-Organizationconfig | fl *ews*
Oplossing
Als u aanvragen voor beschikbaarheid voor meerdere forests op organisatieniveau wilt inschakelen, moet u de gebruikersagent toevoegen aan de lijst ews toestaan. Voeg bijvoorbeeld in de situatie die wordt beschreven in de sectie 'Samenvatting' het volgende gebruikersagentpad toe.
Opmerking
Deze informatie is afkomstig uit IIS-logboeken op de doelserver.
ASProxy/CrossForest/EmailDomain/EXCH/08.03.0083.00
Voer vervolgens de volgende opdracht uit:
Set-OrganizationConfig -EwsAllowList "ASProxy/CrossForest/EmailDomain/EXCH/08.03.0083.000","TestApp","app1"