Problemen met regioservers in Azure HDInsight
In dit artikel worden de stappen voor probleemoplossing en mogelijke oplossingen beschreven voor problemen bij interactie met Azure HDInsight-clusters.
Scenario: Niet-toegewezen regio's
Probleem
Wanneer u de opdracht uitvoert hbase hbck
, ziet u een foutbericht dat lijkt op:
multiple regions being unassigned or holes in the chain of regions
Vanuit de hoofdgebruikersinterface van Apache HBase kunt u het aantal regio's zien dat niet is verdeeld over alle regioservers. Vervolgens kunt u de opdracht uitvoeren hbase hbck
om gaten in de regioketen te zien.
Oorzaak
Gaten kunnen het gevolg zijn van offlineregio's.
Oplossing
Corriseer de toewijzingen. Volg de onderstaande stappen om de niet-toegewezen regio's weer terug te brengen naar de normale status:
Meld u aan bij het HDInsight HBase-cluster met behulp van SSH.
Voer
hbase zkcli
de opdracht uit om verbinding te maken met ZooKeeper Shell.Uitvoeren
rmr /hbase/regions-in-transition
ofrmr /hbase-unsecure/regions-in-transition
opdracht uitvoeren.Sluit zookeeper shell af met behulp van
exit
de opdracht.Open de Apache Ambari-gebruikersinterface en start vervolgens de Active HBase Master-service opnieuw op.
Voer
hbase hbck
de opdracht opnieuw uit (zonder verdere opties). Controleer de uitvoer en zorg ervoor dat alle regio's worden toegewezen.
Scenario: Servers voor dode regio's
Probleem
Regioservers kunnen niet worden gestart.
Oorzaak
Meerdere wal-directory's splitsen.
Lijst met huidige WAL's ophalen:
hadoop fs -ls -R /hbase/WALs/ > /tmp/wals.out
.Inspecteer het
wals.out
bestand. Als er te veel gesplitste mappen zijn (te beginnen met *-splitting), mislukt de regioserver waarschijnlijk vanwege deze mappen.
Oplossing
Stop HBase vanuit de Ambari-portal.
Voer uit
hadoop fs -ls -R /hbase/WALs/ > /tmp/wals.out
om een nieuwe lijst met WAL's op te halen.Verplaats de *-splitting directory's naar een tijdelijke map
splitWAL
en verwijder de *-splitting directory's.Voer de opdracht uit
hbase zkcli
om verbinding te maken met zookeeper shell.Uitvoeren
rmr /hbase-unsecure/splitWAL
.Start de HBase-service opnieuw.
Volgende stappen
Als u uw probleem niet hebt gezien of uw probleem niet kunt oplossen, gaat u naar een van de volgende kanalen voor meer ondersteuning:
Krijg antwoorden van Azure-experts via de ondersteuning van De Azure-community.
Maak verbinding met @AzureSupport : het officiƫle Microsoft Azure-account voor het verbeteren van de klantervaring. De Azure-community verbinden met de juiste resources: antwoorden, ondersteuning en experts.
Als u meer hulp nodig hebt, kunt u een ondersteuningsaanvraag indienen via Azure Portal. Selecteer Ondersteuning in de menubalk of open de Help + ondersteuningshub . Raadpleeg hoe u een ondersteuning voor Azure aanvraag maakt voor meer informatie. Toegang tot abonnementsbeheer en factuurbeheer is in uw Microsoft Azure-abonnement inbegrepen, en technische ondersteuning wordt verstrekt via een van de Azure-ondersteuningsplannen.