Problemen met ConstrainedAllocationFailed oplossen bij het implementeren van een cloudservice (klassiek) in Azure
Belangrijk
Cloud Services (klassiek) is vanaf 1 september 2024 afgeschaft voor alle klanten. Bestaande actieve implementaties worden gestopt en afgesloten door Microsoft en de gegevens gaan vanaf oktober 2024 definitief verloren. Nieuwe implementaties moeten gebruikmaken van het nieuwe op Azure Resource Manager gebaseerde implementatiemodel Azure Cloud Services (uitgebreide ondersteuning).
In dit artikel lost u toewijzingsfouten op waarbij Azure Cloud-services (klassiek) niet kunnen worden geïmplementeerd vanwege toewijzingsbeperkingen.
Wanneer u exemplaren implementeert in een cloudservice (klassiek) of nieuwe exemplaren van een web- of werkrol toevoegt, wijst Microsoft Azure rekenresources toe.
Mogelijk ontvangt u tijdens deze bewerkingen af en toe fouten, zelfs voordat u de limiet voor het Azure-abonnement bereikt.
Tip
De informatie kan ook nuttig zijn wanneer u de implementatie van uw services plant.
Symptoom
Navigeer in Azure Portal naar uw cloudservice (klassiek) en selecteer in de zijbalk het bewerkingslogboek (klassiek) om de logboeken weer te geven.
Wanneer u de logboeken van uw cloudservice (klassiek) inspecteert, ziet u de volgende uitzondering:
Type uitzondering | Foutbericht |
---|---|
ConstrainedAllocationFailed | Azure-bewerking '{Operation ID} ' is mislukt met code Compute.ConstrainedAllocationFailed. Details: Toewijzing is mislukt; kan niet voldoen aan beperkingen in de aanvraag. De aangevraagde nieuwe service-implementatie is gebonden aan een affiniteitsgroep, of is gericht op een virtueel netwerk, of er is een bestaande implementatie onder deze gehoste service. Met een van deze voorwaarden wordt de nieuwe implementatie beperkt tot specifieke Azure-resources. Probeer het later opnieuw of verklein de grootte van de virtuele machine (VM) of het aantal rolinstanties. U kunt indien mogelijk ook de beperkingen verwijderen of proberen te implementeren in een andere regio. |
Oorzaak
Wanneer het eerste exemplaar wordt geïmplementeerd naar een cloudservice (in fasering of productie), wordt die cloudservice vastgemaakt aan een cluster.
Na een bepaalde tijd kunnen de resources in dit cluster volledig worden gebruikt. Als een cloudservice (klassiek) een toewijzingsaanvraag indient voor meer resources wanneer er onvoldoende resources beschikbaar zijn in het vastgemaakte cluster, resulteert de aanvraag in een toewijzingsfout. Zie de veelvoorkomende problemen met toewijzingsfouten voor meer informatie.
Oplossing
Bestaande cloudservices worden vastgemaakt aan een cluster. Eventuele verdere implementaties voor de cloudservice (klassiek) vinden plaats in hetzelfde cluster.
Wanneer u een toewijzingsfout ondervindt in dit scenario, is het raadzaam om opnieuw te implementeren naar een nieuwe cloudservice (klassiek) (en de CNAME bij te werken).
Tip
Deze oplossing is waarschijnlijk het meest succesvol omdat het platform een keuze kan maken uit alle clusters in die regio.
Notitie
Voor deze oplossing is geen downtime nodig.
Implementeer de workload naar een nieuwe cloudservice (klassiek).
- Zie de handleiding Een cloudservice (klassiek) maken en implementeren voor verdere instructies.
Waarschuwing
Als u het IP-adres dat aan deze implementatiesite is gekoppeld niet wilt verliezen, kunt u Oplossing 3 gebruiken : het IP-adres behouden.
Werk de CNAME - of A-record bij om verkeer naar de nieuwe cloudservice (klassiek) te laten verwijzen.
- Zie de handleiding Een aangepaste domeinnaam configureren voor een Azure Cloud-service (klassiek) voor verdere instructies.
Zodra er geen verkeer naar de oude site gaat, kunt u de oude cloudservice (klassiek) verwijderen.
- Zie de handleiding Implementaties en een cloudservice (klassiek) verwijderen voor verdere instructies.
- Zie Inleiding tot cloudservicebewaking (klassiek) als u het netwerkverkeer in uw cloudservice (klassiek) wilt zien.
Zie Problemen met toewijzingsfouten in de cloudservice (klassiek) | Microsoft Docs voor verdere herstelstappen.
Volgende stappen
Voor meer oplossingen voor toewijzingsfouten en achtergrondinformatie:
Als uw Azure-probleem niet wordt opgelost in dit artikel, gaat u naar de Azure-forums op het Microsoft Developer Network (MSDN) en Stack Overflow. U kunt uw probleem posten in deze forums of posten op @AzureSupport op X. U kunt ook een ondersteuning voor Azure aanvraag indienen. Als u een ondersteuningsaanvraag wilt indienen, selecteert u op de pagina Azure-ondersteuning Ondersteuning krijgen.