Kan ikke logge på med SSO hvis ADAL og AD FS brukes i Skype for Business
Opprinnelig KB-nummer: 4508931
Symptomer
Nye brukere kan ikke logge seg på Microsoft Skype for Business 2016 lokalt ved hjelp av enkel pålogging (SSO)-metoden når Azure Active Directory Authentication Library (ADAL) og Active Directory Federation Services (AD FS) brukes.
Eksisterende profiler påvirkes ikke av dette problemet. Nye brukere eller brukere som slettet profilen sin mens de prøvde å logge på, får denne feilmeldingen:
Det oppstod en feil.
Dette problemet oppstår også på nylig avbildede datamaskiner hvis ingen brukerprofil ble opprettet.
Årsak
Dette problemet oppstår fordi standard godkjenningsmetode endres til Web Account Manager (WAM) etter oppgradering til Microsoft Office 2016 versjon 16.0.7967.0000 eller en nyere versjon.
Løsning
Viktig
Følg fremgangsmåten i dette avsnittet nøye. Det kan oppstå alvorlige problemer hvis du endrer registeret feil. Sikkerhetskopier registeret for gjenoppretting i tilfelle det oppstår problemer.
Legg til én av følgende registernøkler:
Legg til nøkkelen i denne undernøkkelen
EnableWAM
:HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Office\16.0\Lync
Navn:
EnableWAM
Type: DWORD (32-biters)
Verdi: 0x00000000Legg til nøkkelen i denne undernøkkelen
EnableWAM
:HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Office\16.0\Lync
Navn:
EnableWAM
Type: DWORD (32-biters)
Verdi: 0x00000000Legg til nøkkelen i denne undernøkkelen
DisableADALatopWAM
:HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Common\Identity
Navn:
DisableADALatopWAM
Type: DWORD (32-biters)
Verdi: 1Obs!
Det finnes en lignende nøkkel med navnet
DisableADALatopWAMOverride
på samme plassering. Denne nøkkelen brukes ikke av Skype for Business. BrukDisableADALatopWAM
hvis du velger dette alternativet.
Mer informasjon
Bruk moderne hybridgodkjenning for å forhindre dette problemet. Hvis du vil ha mer informasjon, kan du se Oversikt over hybrid moderne godkjenning og forutsetninger for å bruke den med lokale Skype for Business- og Exchange-servere.