Del via


Løse manglende samsvar mellom bruker-ID for nettsted i SharePoint eller OneDrive

Symptomer

Når brukere i organisasjonen prøver å få tilgang til et OneDrive- eller SharePoint-nettsted ved hjelp av en ny konto som deler et brukernavn med en tidligere konto, opplever brukerne ett eller flere av følgende problemer:

  • Feilmeldingen «Ingen tilgang»
  • En inkonsekvent brukeropplevelse
  • Et nytt OneDrive-nettsted som har et suffiks som er lagt til den forventede nettadressen, for eksempel https://contoso-my.sharepoint.com/personal/UserA_Contoso_com1 (suffikset kan være et tall eller en GUID)

Årsak

Disse problemene oppstår vanligvis hvis en brukerkonto slettes fra Administrasjonssenter for Microsoft 365, og deretter opprettes en ny konto ved hjelp av brukerhovednavnet (UPN) som ble brukt av den slettede kontoen. Den nye kontoen tilordnes en ny ID-verdi selv om UPN er den samme. UserInfo-listen for SharePoint- og OneDrive-nettstedene som er knyttet til kontoen, har imidlertid bare den gamle ID-en. Når brukere prøver å få tilgang til et SharePoint-nettsted eller OneDrive-nettstedet ved hjelp av den nye kontoen, samsvarer ikke den nye ID-en som er i UserInfo-listen. Derfor blir de nektet tilgang til området.

Disse problemene kan også oppstå under katalogsynkronisering mellom en Organisasjonsenhet for Active Directory (OU) og SharePoint. Hvis brukere allerede har logget på SharePoint og senere flyttes til en annen ou, kan de oppleve disse problemene når OU synkroniserer med SharePoint.

Løsning

Hvis du vil løse disse problemene, kjører du diagnosedata for områdebrukerkonflikt ved hjelp av en SharePoint-administratorkonto.

Obs!

  • Denne diagnosen er ikke tilgjengelig for GCC High- eller DoD-miljøer, eller for Microsoft 365 drevet av 21Vianet.
  • Før administratorer kjører diagnosen for å løse problemene for OneDrive-nettsteder, må de sørge for at brukernavnet til den nye brukerkontoen samsvarer med den gamle kontoen. Administratorer har ikke lov til å koble til OneDrive-nettsteder som kan ha vært eid tidligere av en annen brukerkonto. 
  • Hvis diagnosen har løst et problem som er relatert til et OneDrive-nettsted, kan endringene ta omtrent 24 timer. Denne perioden inkluderer oppdatering av OneDrive-flisen for å peke til riktig nettsted og resirkulere eventuelle ekstra OneDrive-nettsteder.

Velg følgende Kjør tester-knappen for å fylle ut diagnosen i Administrasjonssenter for Microsoft 365. Diagnosen utfører et stort utvalg valideringer for interne brukere og gjester som prøver å få tilgang til SharePoint- og OneDrive-nettsteder.

Når du blir bedt om det, oppgir du følgende informasjon:

  • Den berørte brukerkontoen, for eksempel UserA@contoso.com
  • Den opprinnelige url-adressen for området, for eksempel https://contoso-my.sharepoint.com/personal/UserA_Contoso_com

Følg disse trinnene for å få den opprinnelige nettadressen for OneDrive-nettstedet:

  1. Logg på OneDrive-nettstedet ved hjelp av en administratorkonto.
  2. Velg Innstillinger (tannhjul)-ikonet øverst til høyre.
  3. Velg OneDrive-innstillinger, og velg deretter Flere innstillinger.
  4. Kopier nettadressen for OneDrive-nettadressen fra diagnoseinformasjon-delen .

Hvis du vil hente flere Nettadresser for OneDrive, bruker du én av metodene i Vis nettadresser for OneDrive for brukere i organisasjonen.

Vanlige scenarier

Diagnoseverktøyet for områdebrukerkonflikt kan løse følgende vanlige problemer som kan oppstå når en ny konto opprettes ved hjelp av UPN som ble brukt av en slettet konto.

En bruker blir dirigert til et nytt OneDrive-nettsted som har et suffiks som er lagt til den forventede nettadressen

Når en ny brukerkonto opprettes, tilordnes et nytt OneDrive-nettsted til den. Når en brukerkonto slettes, slettes ikke OneDrive-nettstedet som er tilordnet kontoen umiddelbart. Så hvis en ny brukerkonto opprettes ved hjelp av UPN for en slettet konto, har det nye OneDrive-nettstedet som er tilordnet til den nye kontoen, den samme nettadressen som det gamle OneDrive-nettstedet sammen med et ekstra suffiks. Dette suffikset er enten et tall eller en GUID.

Hvis du vil at den nye brukerkontoen skal bruke det samme OneDrive-nettstedet som ble tilordnet til den gamle kontoen, vil diagnosen kontrollere om brukeren kan tilordnes eierskap av det opprinnelige nettstedet. Når du har bekreftet brukerens tillatelser, vil diagnosen tilby å koble brukeren til det opprinnelige nettstedet og resirkulere det nye aktive nettstedet som har suffikset, for eksempel https://contoso-my.sharepoint.com/personal/UserA_Contoso_com1.

Hvis du må få tilgang til innhold på det nye OneDrive-nettstedet senere, kan du gjenopprette den slettede OneDrive.

Ingen tilgang til et OneDrive-nettsted

Hvis en bruker nektes tilgang til det gamle OneDrive-nettstedet etter at en ny konto er opprettet for dem, konfigurerer diagnosen brukerens profil på nytt. Deretter kobler den brukeren til det gamle OneDrive-nettstedet på nytt for å løse tilgangsproblemet.

Obs!

Administratorer kan ikke løse dette problemet ved å oppdatere eierne av OneDrive-nettstedet manuelt eller redigere brukerprofilegenskapene som er knyttet til OneDrive-nettstedet. Diagnosen er den eneste anbefalte løsningen for å løse dette problemet.

Manglende samsvar med bruker-ID på SharePoint-nettsteder eller OneDrive-nettsteder som ikke tilhører brukeren

Når diagnosen oppdager en bruker-ID-feil i UserInfo-listen, vil den tilby å fjerne den gamle ID-en. Når du har godtatt tilbudet og den gamle ID-en er fjernet, tilordner du den nye brukerkontoen de riktige tillatelsene til SharePoint-området.

Obs! Hvis du vil løse dette problemet manuelt, må du fjerne den gamle brukerkontoen fra UserInfo-listen og deretter gi tillatelser til den nye brukerkontoen.

Mer informasjon

Hvis du vil ha mer informasjon om tilgangsproblemer i SharePoint og OneDrive, kan du se Feilmeldingen «Ingen tilgang» eller «Du trenger tillatelse» i SharePoint Online og OneDrive.