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Active Directory 진단 템플릿을 사용하여 Perfmon.exe 실행하여 도메인 컨트롤러에서 보고서를 생성할 때 보고서 생성 프로세스가 응답하지 않을 수 있습니다.

이 문서에서는 Active Directory 진단 템플릿을 사용하여 Perfmon.exe 실행하여 보고서를 생성할 때 보고서 생성 프로세스가 응답하지 않는 문제를 해결하는 데 도움이 됩니다.

원래 KB 번호: 971714

증상

Active Directory 진단 템플릿을 사용하여 Perfmon.exe 실행하여 Windows Server 도메인 컨트롤러에서 보고서를 생성하는 경우 프로세스가 응답하지 않을 수 있습니다.

원인

이 문제는 TraceRpt.exe 도구를 실행하는 안정성 및 성능 모니터(Perfmon.exe) 콘솔이 보고서 생성 프로세스 중에 너무 많은 메모리 및 CPU 리소스를 소비하기 때문에 발생합니다. Windows Server가 사용 중이고 리소스가 부족한 경우 보고서 생성 프로세스의 응답이 중지됩니다.

해결

이 문제를 해결하려면 서버 역할이 동일하고 하드웨어 리소스가 충분한 다른 컴퓨터에 파일을 복사합니다. 그런 다음 파일과 함께 TraceRpt.exe 실행합니다. 이렇게 하려면 다음 단계를 수행하세요.

  1. 안정성 및 성능 모니터(Perfmon.exe) 콘솔에서 데이터 수집기 집합을 클릭한 다음 시스템을 클릭합니다.

  2. Active Directory 진단을 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다. 파일 수집 프로세스는 Windows Server 도메인 컨트롤러에서 시작됩니다.

  3. 보고서 상태가 시간> 동안<데이터 수집에서 보고서 생성으로 변경된 후**, 파일을 두 번째 Windows Server 도메인 컨트롤러에 복사합니다.

    참고 항목

    다음 위치에서 파일을 찾을 수 있습니다. %systemdrive%\Perflogs\ADDS\ 날짜 보고서 생성 실행 \*

    Ths "-df" 스위치는 Perfmon을 사용하여 생성된 Microsoft 특정 카운팅/보고 스키마 파일을 지정하는 것입니다. 이 파일 이름은 report.xsl입니다.

  4. 파일을 찾은 다음 두 번째 Windows Server 도메인 컨트롤러의 명령줄에서 다음 명령을 실행합니다.

    tracerpt *.blg *.etl -df *PerfmonSchemaFileName.xsl* -report *your_report.html* -f html **** ****
    
  5. Windows Internet Explorer를 사용하여 생성된 .html 파일을 봅니다.