Windows에서 NMI가 트리거될 때 NMI_HARDWARE_FAILURE 오류
이 문서에서는 NMI(마스킹할 수 없는 인터럽트)가 트리거될 때 NMI_HARDWARE_FAILURE 오류가 발생하는 디자인별 동작에 대해 설명합니다.
원래 KB 번호: 2750146
증상
Windows 컴퓨터에서 사용자가 컴퓨터에서 NMI 스위치를 수동으로 누르거나 하드웨어 오류로 인해 NMI가 트리거될 수 있습니다.
이 이벤트에서 Windows는 실행을 중지하고 "PC에 문제가 발생하여 다시 시작해야 합니다"라는 파란색 화면을 표시합니다. 여기에는 NMI_HARDWARE_FAILURE 오류 코드가 포함됩니다.
그러면 컴퓨터가 메모리 덤프 파일을 저장할 수 있으며 시스템 제어판의 "고급 시스템 설정"에서 "시작 및 복구"에 지정된 설정에 따라 자동으로 다시 부팅될 수 있습니다.
원인
NMI가 발생할 때의 동작은 이전 버전의 Windows에 비해 변경되었습니다. Windows 7, Windows Server 2008 R2 및 이전 버전에서 시스템에서 NMI가 발견되었을 때의 응답은 "NMICrashDump" 레지스트리 값의 구성에 따라 달라집니다.
이전 Windows 버전의 NMICrashDump 레지스트리 값 및 NMII 처리에 대한 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료의 문서를 확인합니다.
927069 Windows 기반 시스템에서 NMI를 사용하여 전체 크래시 덤프 파일 또는 커널 크래시 덤프 파일을 생성하는 방법
Windows 8 및 Windows Server 2012에서는 이 동작을 구성할 수 없습니다. NMI는 항상 버그 검사 0x80(NMI_HARDWARE_FAILURE) 발생합니다. 이는 "NMICrashDump" 레지스트리 값이 있고 값 1로 설정된 이전 Windows 버전의 동작과 동일합니다.
자세한 정보
이 동작은 의도된 것입니다.