Kerberos 티켓의 KRB_AP_ERR_TKT_EXPIRED 오류
이 문서는 Kerberos 티켓에 영향을 줄 수 있는 일관된 인증 문제를 해결하는 데 도움이 됩니다.
Kerberos는 클라이언트 또는 서버 애플리케이션에 대한 보안 인증을 제공하기 위해 비밀 키를 사용하는 프로토콜입니다. 성공적인 인증을 위해 사용자에게 티켓이 발급됩니다. 일반적으로 Kerberos 티켓의 수명은 약 10시간이며 자동으로 갱신됩니다.
증상
KDC(키 배포 센터)에는 서비스가 실패했음을 나타내는 오류 메시지가 표시됩니다 KRB_AP_ERR_TKT_EXPIRED
.
원인
사용자가 인증에 만료된 티켓을 사용하려고 하면 Kerberos 연결이 실패합니다. 자세한 내용은 Kerberos 인증 문제 해결 지침을 참조 하세요.
해결
이 문제를 해결하려면 다음 단계를 따릅니다.
명령을
KLIST purge
사용하여 사용자 티켓을 지우거나 로그오프한 후 다시 켜거나 컴퓨터를 다시 시작합니다.KLIST
다음 명령과 같이 SSPIClient 도구와 함께 명령을 사용하여 Kerberos 티켓 및 SPN(서비스 사용자 이름)을 보고 관리합니다.KLIST GET MSSQLSvc\SQLProd01.contoso.com:1433