SessionHasLoggedOff는 클라우드와 연결된 데스크톱 흐름 실행 중에 발생합니다.
이 문서에서는 Microsoft Power Automate의 클라우드 환경에서 데스크톱 흐름을 실행하는 동안 SessionHasLoggedOff 오류 코드를 수신하는 문제에 대한 문제 해결 단계를 제공합니다.
증상
클라우드 환경에서 데스크톱 흐름을 실행하는 동안 "실행 실행 중에 로그오프된 세션" 메시지와 함께 오류 코드가 표시됩니다 SessionHasLoggedOff
.
{
"error":{
"code": "SessionHasLoggedOff",
"message": "The session logged off during run execution."
}
}
원인
데스크톱 흐름을 실행하는 Windows 세션이 시스템에서 로그아웃되었기 때문에 오류 코드가 발생합니다. 이 문제는 수동 사용자 작업 또는 컴퓨터에서 실행되는 타사 소프트웨어로 인해 발생할 수 있습니다.
문제 해결 단계
문제를 조사하려면 다음 단계를 수행합니다.
사용자 지정 스크립트 확인: 데스크톱 흐름에 세션이 로그아웃되거나 컴퓨터가 다시 시작될 수 있는 사용자 지정 스크립트(예: 배치 파일 또는 PowerShell 스크립트)가 없는지 확인합니다.
그룹 정책 설정 확인: 시간 제한으로 인해 원격 데스크톱 세션에서 로그아웃하도록 구성된 그룹 정책 설정이 없는지 확인합니다. 로컬 그룹 정책 편집기를 열고 컴퓨터 구성>관리 템플릿>Windows 구성 요소>원격 데스크톱 서비스>세션 시간 제한으로 이동하여 이러한 설정을 확인할 수 있습니다.
완료 시간: 데스크톱 흐름 실행이 완료된 시간을 기록합니다.
Windows 이벤트 뷰어 로그를 검토합니다.
흐름을 실행하는 컴퓨터로 이동하여 Windows 이벤트 뷰어 엽니다.
애플리케이션 및 서비스 로그>Microsoft>Windows>TerminalServices-LocalSessionManager로 이동하여 로컬 세션 관리자 로그를 확인합니다.
완료 시간을 참조로 사용하여 로그아웃 시간에 해당하는 로그를 찾습니다. 해당 시간부터 몇 분 전까지 로그를 확인합니다.
원인을 식별합니다.
- 세션 0에서 실행되는 프로세스 또는 사용자 작업과 같이 세션 연결이 끊어질 수 있는 원인에 대한 표시를 찾습니다.
- 이벤트 ID가 40인 이벤트가 표시되면 세션이 이유 코드와 연결이 끊어졌습니다.
타사 소프트웨어 확인: 타사 소프트웨어로 인해 연결이 끊어진 경우 Windows 로그>애플리케이션에서 연결 끊김의 타임스탬프 주위에 있는 로그를 확인하여 애플리케이션이 관련 정보를 기록했는지 확인합니다.