MDM이 등록된 Windows 10 디바이스에서 Sysprep이 제대로 실행되지 않습니다.
이 문서에서는 MDM(모바일 디바이스 관리)에 등록된 Windows 10 디바이스에서 Sysprep이 제대로 실행되지 않는 경우에 대한 문제 해결 팁을 제공합니다.
증상
복제하기 전에 이미지 또는 VM(가상 머신)과 같은 운영 체제(OS)에서 Sysprep(시스템 준비) 도구를 실행해야 합니다. Sysprep을 실행할 때 일반화 프로세스는 생성된 원래 컴퓨터에서 모든 고유 정보를 제거할 것으로 예상합니다.
그러나 이 제거는 몇 가지 주요 항목에 대해 발생하지 않습니다.
MDM 등록(예: Intune) 인증서, 식별자, 설정 등
Microsoft Entra 조인 또는 Microsoft Entra 디바이스 등록 인증서 및 ID.
이 문제로 인해 여러 디바이스에 동일한 ID가 부여되고 MDM 서버에서 필요한 구성을 받지 못하므로 MDM에 심각한 문제가 발생합니다.
원인
컴퓨터를 일반화하기 위해 Sysprep을 실행하면 모든 Windows 구성 요소에서 레지스트리 키, 인증서, 파일, 폴더 등과 같은 정보를 시스템에서 제거할 수 있습니다. 해당 설치가 복제된 경우 구성 요소에서 알고 있는 모든 항목에 문제가 발생합니다.
그렇다고 모든 구성 요소가 정보를 제거하는 것은 아닙니다.
예: Windows 10 설치를 Microsoft Entra ID에 가입하거나 Intune에 등록하면 OS는 특정 디바이스에 연결된 여러 인증서를 받게 됩니다. 추가 등록 및 디바이스 ID 정보는 레지스트리의 다양한 위치에 기록된 다음 정책 정보와 설정이 모두 적용됩니다. 따라서 해당 정보는 sysprep 또는 일반화 프로세스에 의해 제거되지 않습니다.
솔루션
Windows 설치를 복제하거나 복제하려면(디스크 드라이브를 물리적으로 복제하든, VM 기반 스냅샷을 사용하든, 다른 디스크 기술을 사용하든) 시스템은 Sysprep.exe 사용하여 일반화되어야 합니다.
중복되거나 이미지화된 Windows 설치를 배포하는 경우 이미지를 캡처하기 전에 Sysprep을 사용해야 합니다. Microsoft는 Sysprep 이외의 SID 중복 도구를 사용하여 설정된 컴퓨터에 대한 지원을 제공하지 않습니다. 이미지를 캡처하고 배포하기 전에 Windows 이미지를 다시 봉인하거나 일반화합니다.
예를 들어 Sysprep 도구를 사용하여 이미지를 일반화하는 경우 Sysprep은 모든 시스템 관련 정보를 제거하고 컴퓨터를 초기화합니다. Windows 이미지를 다른 컴퓨터로 전송하는 경우 다른 컴퓨터에 동일한 하드웨어 구성이 있더라도 Sysprep 명령을 옵션과 /generalize
함께 실행해야 합니다. Sysprep /generalize
명령은 다른 컴퓨터에서 해당 이미지를 다시 사용할 수 있도록 Windows 설치에서 고유한 정보를 제거합니다.
또한 Microsoft Entra ID에 조인되거나 Intune과 같은 MDM 서비스에 등록된 디바이스를 복제하지 마세요. 그렇지 않으면 해당 이미지를 사용하는 모든 디바이스가 사용자와 동일하게 표시되고, Intune은 모두 동일한 디바이스 ID와 인증서를 제공할 때 구분할 수 없습니다.
이미지를 만들 때 VM을 사용하고 전체 프로세스를 완료할 수 있는 자동화된 작업 순서를 실행하는 동안 일관되고 반복 가능한 프로세스(예: MDT 또는 ConfigMgr OSD 사용)를 따릅니다. Active Directory 또는 Microsoft Entra ID에 조인하지 말고 Intune에 이미 등록되어 있으므로 이미지를 공동 관리 상태로 설정하지 마세요. 이미지를 작업 그룹에 유지하고, 사용자 지정을 수행하고, 프로세스가 끝날 때 실행 sysprep /generalize
합니다.
여기에 설명된 많은 문제를 무시하려면 Windows Autopilot을 사용하여 프로세스를 자동화하는 것이 좋습니다.