자동 레코드 생성 및 업데이트 규칙으로 일반적인 구성 문제 해결
이 문서에서는 레코드 만들기가 실패하거나 건너뛸 수 있으므로 자동 레코드 만들기 및 업데이트 규칙이 있는 일반적인 구성 실패 시나리오에 대한 해결 방법을 제공합니다.
시나리오 1
샘플: 자동 레코드 만들기 및 업데이트 규칙에 대한 구성
- 알 수 없는 발신자에 대한 연락처 만들기 옵션을 선택해야 합니다.
- 모든 수신 전자 메일에 대한 조건 기준을 설정합니다.
- 사례를 만들고, 속성 보기를 선택하고, 비즈니스 사용 사례별로 사례 필드를 설정하는 작업을 추가합니다.
오류 1 - "케이스에 고객이 없습니다."
CASE DETAILS 섹션의 고객 필드에서 보낸 사람 계정(전자 메일) 값은 아래와 같이 설정됩니다.
이 설정을 사용하면 시스템 작업에서 다음과 같은 오류가 발생합니다.
이 경우 고객이 누락되었습니다.
오류 1에 대한 해결 방법
이 문제를 해결하려면 고객 필드를 비워 두거나 {Sender(전자 메일)}로 설정합니다. 이렇게 하면 시스템에서 알 수 없는 발신자에 대한 연락처를 자동으로 만들어 사례에 연결할 수 있습니다.
오류 2 - "오류가 발생했습니다."
고객 필드는 {보낸 사람 계정(전자 메일)}으로 설정되고 연락처 필드는 {Sender(Email)}로 설정됩니다.
이 설정을 사용하면 시스템 작업에서 다음과 같은 오류가 발생합니다.
오류가 발생했습니다. 이 작업을 다시 시도하세요. 문제가 계속되면 Microsoft Dynamics 365 커뮤니티 확인하여 솔루션을 확인하거나 조직의 Microsoft Dynamics 365 관리자에게 문의하세요. 마지막으로 Microsoft 지원 문의할 수 있습니다.
오류 2 해결
이 문제를 해결하려면 고객 필드를 비워 두거나 {Sender(전자 메일)}로 설정합니다. 이렇게 하면 시스템에서 알 수 없는 발신자에 대한 연락처를 자동으로 만들어 사례에 연결할 수 있습니다.
오류 3 - "지정된 연락처가 고객 필드에 지정된 연락처에 속하지 않습니다."
고객 및 연락처 필드는 {Sender(전자 메일)}로 설정됩니다.
이 설정을 사용하면 시스템 작업에서 다음과 같은 오류가 발생합니다.
지정된 연락처가 고객 필드에 지정된 연락처에 속하지 않습니다. 연락처 필드에서 값을 제거하거나 선택한 고객과 연결된 연락처를 선택한 다음 다시 시도합니다.
오류 3 해결
이 문제를 해결하려면 연락처 필드를 비워 두고 고객 필드를 비워 두거나 {Sender(전자 메일)}로 설정합니다.
유효성 검사 단계
문제의 주요 원인을 파악하고 해결하려면 다음 표에 제공된 구성 및 유효성 검사 단계의 유효성을 검사해야 합니다.
서비스 관리에서 자동 레코드 만들기 및 업데이트 규칙의 옵션 | 다음과 같이 선택된 경우 | 유효성 검사 단계 | 결과 |
---|---|---|---|
고객에 대해 유효한 권리 유형이 있을 경우 서비스 케이스 만들기 | 지원 | 고객에 대해 활성 권리 유형이 있는지 유효성을 검사합니다. 유효한 활성 자격은 다음과 같이 평가됩니다. - 전자 메일의 발신자가 부모 계정과의 연락처인 경우 Dynamics 365 고객 서비스는 연락처의 부모 계정에 유효한 자격이 있고 연락처가 자격 의 연락처 섹션에 나열된 경우 사례를 만듭니다. 또는 연락처 섹션이 비어 있는 경우(즉, 고객의 모든 연락처에 자격이 적용됨) |
케이스가 만들어집니다. |
알 수 없는 보낸 사람이 보낸 전자 메일에서 서비스 케이스 만들기 | 지원 | 알 수 없는 보낸 사람으로부터 받은 수신 전자 메일의 경우 | - 케이스가 만들어집니다. - 알 수 없는 보낸 사람에게도 연락처가 만들어집니다. |
Yes | 비활성 계정 또는 연락처의 전자 메일 주소가 포함된 수신 전자 메일의 경우 | - 케이스가 만들어집니다. - 비활성 계정 또는 연락처가 활성화됩니다. |
|
No | 활성 계정 또는 연락처의 전자 메일 주소가 포함된 수신 전자 메일의 경우 | 케이스가 만들어집니다. | |
No | 거래처 또는 연락처 이외의 레코드 종류에서 보낸 수신 전자 메일의 경우 | 대/소문자를 만들지 않습니다. | |
No | 비활성 계정 또는 연락처의 전자 메일 주소가 포함된 수신 전자 메일의 경우 | 대/소문자를 만들지 않습니다. | |
해결된 서비스 케이스와 연관된 활동의 서비스 케이스 만들기 | 지원 | 해결된 서비스 케이스와 관련된 수신 전자 메일의 경우 | 케이스가 만들어집니다. |
Yes | 활성 서비스 케이스와 관련된 수신 전자 메일의 경우 | 대/소문자를 만들지 않습니다. |
시나리오 2 - 레거시 환경에서 {Regarding(Email)}을(를) 사용하면 흐름에서 올바른 데이터를 제공하지 않습니다.
고객 서비스의 레거시 "자동 레코드 만들기 및 업데이트 규칙" 항목에서 전자 메일을 보내는 엔터티(연락처 또는 계정)를 조회하려면 해당 엔터티를 자동으로 가져오고 엔터티 이름을 표시하는 보낸 사람(전자 메일) 다형 조회를 사용할 수 있습니다. 다형성 조회는 조회 대상이 한 종류 이상의 엔터티인 조회입니다. 예를 들어 연락처 또는 거래처를 가리킬 수 있습니다. 그러나 최신 "자동 레코드 만들기 및 업데이트 규칙"에서는 이 자동 표시가 지원되지 않으므로 해당 엔터티에서 표시할 필드와 함께 검색할 엔터티 유형을 지정해야 합니다.
원인
흐름 식은 이전 흐름 단계의 페이로드 중 하나에서 데이터 값을 참조하기 때문에 흐름은 레거시 워크플로와 같은 {Regarding(Email)} 값을 사용하지 않습니다. 예를 들어 흐름이 시작될 때 {Regarding(Email)} 값이 비어 있으면 {Regarding(Email)}에 대한 트리거 단계 페이로드의 값은 비어 있습니다. 사례를 만든 후 {Regarding(Email)} 값이 업데이트되더라도 전자 메일 레코드 데이터는 업데이트되지만 흐름의 페이로드는 업데이트되지 않습니다. 따라서 페이로드의 값이 후속 흐름 단계에서 참조될 때 비어 있습니다.
해결
레거시 규칙 항목에서 {Regarding(Email)} 값을 사용하는 경우 "인시던트 ID" 또는 "OData ID"를 사용하도록 마이그레이션된 흐름을 수동으로 업데이트해야 합니다. 엔터티 참조 또는 조회가 필요한 필드에는 "OData ID"를 사용합니다. GUID가 필요한 필드에 대/소문자 고유 식별자를 사용합니다.
시나리오 3 - 레거시에서 최신 "자동 레코드 만들기 및 업데이트 규칙"으로 마이그레이션하는 동안 비 조회 필드에 다형 조회를 렌더링하는 문제
보낸 사람 등의 다형 조회를 사용하는 레거시 "자동 레코드 만들기 및 업데이트 규칙" 항목은 텍스트 필드에 할당할 때 잘못된 조회를 생성합니다.
고객 서비스의 레거시 "자동 레코드 만들기 및 업데이트 규칙" 항목에서 전자 메일을 보낸 엔터티(연락처 또는 계정)를 조회하려면 해당 엔터티를 자동으로 가져오고 엔터티 이름을 표시하는 보낸 사람(전자 메일) 다형 조회를 사용할 수 있습니다. 다형성 조회는 조회 대상이 한 종류 이상의 엔터티인 조회입니다. 예를 들어 연락처 또는 거래처를 가리킬 수 있습니다. 그러나 최신 "자동 레코드 만들기 및 업데이트 규칙"에서는 이 자동 표시가 지원되지 않습니다. 따라서 해당 엔터티에서 표시할 필드와 함께 검색할 엔터티의 형식을 지정해야 합니다.
원인
레거시 "자동 레코드 만들기 및 업데이트 규칙"에서 사용하는 클래식 워크플로 동작에는 많은 숨겨진 동작이 있습니다. 예를 들어 매개 변수가 문자열에 사용되는 경우 엔터티 형식을 자동으로 결정하고 필드를 표시 이름으로 가져오지만 조회 필드에 할당된 경우 ID를 반환합니다. 레거시에서 최신 워크플로로 변환할 때 "자동 레코드 만들기 및 업데이트 규칙"에서 사용하는 플랫폼 마이그레이션 코드는 필요한 단계와 필드를 추가하지 않습니다.
해결
이 문제를 해결하려면
- 조회를 특정 유형으로 업데이트합니다.
- 원하는 텍스트를 포함하는 수신 엔터티에서 다른 필드를 사용하십시오.