다음을 통해 공유


InvalidResourceReference 오류 코드 문제 해결

이 문서에서는 AKS(Microsoft Azure Kubernetes Service) 클러스터를 만들고 배포하거나 AKS 클러스터를 업데이트하려고 할 때 발생할 수 있는 오류를 식별하고 해결하는 InvalidResourceReference 방법을 설명합니다.

증상 1

AKS 클러스터를 만들려고 하면 다음과 같은 오류 메시지가 표시됩니다.

Code="InvalidResourceReference"

Message="Resource
/subscriptions/<subscription-id-guid>/resourceGroups/MyResourceGroup/providers/Microsoft.Network/virtualNetworks/vnet-otcom/subnets/Subnet-AKS
리소스에서 참조
/subscriptions/<subscription-id-guid>/resourceGroups/MC_MyResourceGroup_MyCluster-AKS_JAPANEAST/providers/Microsoft.Compute/virtualMachineScaleSets/aks-nodepool-vmss
찾을 수 없습니다. 참조된 리소스가 있고 두 리소스가 동일한 지역에 있는지 확인하세요."

Details=[]

원인 1

이 문제의 가능한 원인은 다음과 같습니다.

  • 다른 지역의 리소스 간에 불일치가 있습니다.

    증상 1예제에서는 가상 네트워크와 가상 머신 확장 집합이 동일한 지역에 있지 않음을 보여 줍니다. 리소스가 서로 다른 지역에 있으므로 확장 집합 인스턴스를 만드는 것은 불가능합니다.

  • 참조된 리소스가 수동으로 수정되거나 삭제되었습니다.

솔루션 1

다른 지역의 리소스 간에 불일치가 있는 경우 리소스를 검토하여 동일한 지역에 있는지 확인합니다. 이 예제에서는 AKS 클러스터가 빌드되는 지역을 수정하거나 동일한 지역에 새 가상 네트워크를 만듭니다.

참조된 리소스가 수동으로 수정되거나 삭제된 경우 MC_ 리소스 그룹의 기본 IaaS 리소스 를 수동으로 수정하는 것이 지원되지 않으므로 이 문제를 해결하기 어려울 수 있습니다. 가능한 해결 방법은 삭제된 리소스를 다시 만들고 VMSS와 다시 연결한 다음 AKS 클러스터에서 업데이트를 트리거하는 것입니다. 그러나 지원되지 않는 시나리오이므로 이 솔루션의 성공을 보장할 수 없습니다.

증상 2

AKS 클러스터를 업데이트하려고 하면 다음과 같은 오류 메시지가 표시됩니다.

Code="InvalidResourceReference"
Message="Resource
/subscriptions/<subscription-id-guid>/resourceGroups/MC_MyResourceGroup/providers/Microsoft.Network/loadBalancers/kubernetes/frontendIPConfigurations/<frontendIP_ID> resource /subscriptions/subscription-id-guid>/<resourceGroups/MC_MyResourceGroup/providers/Microsoft.Network/loadBalancers/kubernetes/loadBalancingRules/<frontend_IP_rule> 찾을 수 없습니다. 참조된 리소스가 있고 두 리소스가 동일한 지역에 있는지 확인하세요."
Message="Resource

Details=[]

원인 2

이 문제는 부하 분산 장치의 기본 아웃바운드 규칙 "aksOutboundRule"이 수동으로 수정되는 경우에 발생할 수 있습니다. 이 예기치 않은 수정은 일반적으로 매개 변수 없이 load-balancer-outbound-ips 클러스터를 업데이트하는 경우 아웃바운드 IP가 업데이트되는 경우에 발생합니다.

해결 방법 2

매개 변수를 사용하여 az aks update load-balancer-outbound-ips 명령을 다시 실행하여 클러스터를 업데이트합니다. 공용 IP의 리소스 ID를 매개 변수 값으로 사용합니다. 자세한 내용은 고유한 아웃바운드 공용 IP로 클러스터 업데이트를 참조하세요.

자세한 정보

AKS 클러스터 만들기 문제의 일반적인 문제 해결

도움을 요청하십시오.

질문이 있거나 도움이 필요한 경우 지원 요청을 생성하거나Azure 커뮤니티 지원에 문의하세요. Azure 피드백 커뮤니티에 제품 피드백을 제출할 수도 있습니다.