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오류 AADSTS750054 - SAML 리디렉션 바인딩에 대한 HTTP 요청의 쿼리 문자열 매개 변수로 SAMLRequest 또는 SAMLResponse가 있어야 함

이 문서에서는 Microsoft Entra ID와 통합된 SAML 기반 SSO(Single Sign-On) 구성된 앱에 로그인하려고 할 때 "오류 AADSTS750054 - SAMLRequest 또는 SAMLResponse가 SAML 리디렉션 바인딩에 대한 HTTP 요청에 쿼리 문자열 매개 변수로 있어야 합니다."라는 오류 메시지가 표시되는 문제를 설명합니다.

증상

SAML 기반 SSO를 사용하여 ID 관리에 Microsoft Entra ID를 사용하도록 설정되었던 애플리케이션에 로그인하려고 할 때 오류가 AADSTS750054 발생합니다.

원인

Microsoft Entra ID가 HTTP 요청의 URL 매개 변수 내에서 SAML 요청을 식별할 수 없었습니다. 이 문제는 애플리케이션이 MICROSOFT Entra ID로 SAML 요청을 보낼 때 HTTP 리디렉션 바인딩을 사용하지 않는 경우에 발생할 수 있습니다.

해결

애플리케이션에서 HTTP 리디렉션 바인딩을 사용하여 인코딩된 SAML 요청을 위치 헤더로 전송해야 합니다. 구현 방법에 대한 자세한 내용은 SAML 프로토콜 사양 문서의 HTTP 리디렉션 바인딩 섹션을 참조하세요.

대부분의 경우 오류는 다음 문제 중 하나로 인해 발생합니다.

  1. 애플리케이션 쪽에서 Single Sign-On이 사용하도록 설정되어 있는지 확인합니다.
  2. 애플리케이션은 서비스 공급자가 시작한 Single Sign-On(SP 시작 SSO라고도 함)을 지원해야 합니다. ID 공급자가 시작한 Single Sign-On만 지원하는 애플리케이션에 대한 로그인 URL을 입력하면 SAML 응답 없이 애플리케이션에서 반송될 수 있습니다.
  3. 로그온 URL이 올바르게 구성되었는지 확인합니다.

Microsoft Entra 관리 센터에서 테스트 SSO 함수 사용

Microsoft Entra 관리 센터는 SAML 구성 오류를 해결하는 데 도움이 될 수 있습니다.

Microsoft Entra 관리 센터의 SSO 기능 테스트 스크린샷

  1. Microsoft Entra 관리 센터에서 엔터프라이즈 애플리케이션으로 이동하여 문제 해결이 필요한 애플리케이션을 클릭합니다.
  2. 왼쪽 탐색 메뉴를 사용하여 Single Sign-On 페이지로 이동합니다.
  3. 이 애플리케이션 테스트를 클릭하여 테스트 SSO 기능을 사용합니다.
  4. 받은 오류를 복사하여 오류 해결 섹션에 붙여넣고 해결 지침 가져오기를 클릭합니다.
  5. 단계에 따라 오류 문제 해결 AADSTS750054

추가 정보

Active Directory 인증 및 권한 부여 오류 코드의 전체 목록은 Microsoft Entra 인증 및 권한 부여 오류 코드를 참조 하세요.

도움을 요청하십시오.

질문이 있거나 도움이 필요한 경우 지원 요청을 생성하거나Azure 커뮤니티 지원에 문의하세요. Azure 피드백 커뮤니티에 제품 피드백을 제출할 수도 있습니다.