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Complete-MigrationBatch 명령에서 "활성 공용 폴더 사서함을 찾을 수 없음" 오류 및 마이그레이션 일괄 처리 실패

증상

공용 폴더를 Microsoft Exchange Server 2019, 2016 또는 2013 온-프레미스에서 Exchange Online으로 마이그레이션하고 있습니다. 온-프레미스 환경에는 여러 AD(Active Directory) 도메인이 있습니다.

명령을 실행 Complete-MigrationBatch 하면 마이그레이션 일괄 처리가 실패한 상태로 전환되고 다음 오류 메시지가 생성됩니다.

Get-MigrationBatch 명령의 스크린샷.

Complete-MigrationBatch 오류 메시지의 스크린샷

"No active public folder mailboxes were found. This happens when no public folder mailboxes are provisioned or they are provisioned in 'HoldForMigration' mode."

원인

이 문제는 공용 폴더 사서함 및 연결된 사용자 계정이 동일한 AD 도메인에 없기 때문에 발생합니다. 예를 들어 공용 폴더 사서함과 연결된 사용자 계정은 contoso.com 있으며 사서함은 child.contoso.com Exchange Server에서 호스트됩니다.

해결

이 문제를 해결하려면 공용 폴더 사서함과 연결된 AD 계정을 Exchange Server를 호스트하는 동일한 AD 도메인으로 이동합니다. 예를 들어 Exchange Server는 루트 AD 도메인(contoso.com)에 설치되고 공용 폴더 사서함과 연결된 AD 계정은 자식 도메인(child.contoso.com)에 있습니다. 이 경우 공용 폴더 사서함과 연결된 AD 계정을 루트 도메인(contoso.com)으로 이동한 다음 명령을 다시 실행합니다 Complete-MigrationBatch . 운영 체제 버전에 따라 Active Directory 마이그레이션 도구 또는 Move-ADObject 명령을 사용하여 AD 사용자를 도메인 간에 이동할 수 있습니다.

예를 들어 다음 PowerShell 명령을 실행하여 PFMBX4연결된 AD 사용자를 child.contoso.com contoso.com 이동합니다.

Move-ADObject -Identity "CN=PFMBX4,CN=Users,DC=Child,DC=contoso,DC=com" -TargetPath "CN=Users,DC=contoso,DC=com" -TargetServer dc1.contoso.com