MSMQ 어댑터의 알려진 문제
이 섹션에서는 오류를 방지하는 데 유용한 정보를 제공합니다.
알려진 문제
MSMQ 어댑터 수신 위치에서 문서를 처리하지 않습니다.
문제
MSMQ 어댑터 수신 위치에서 문서를 처리하지 않습니다.
원인
MSMQ 어댑터 수신 핸들러가 실행 중인 BizTalk 호스트 인스턴스와 연결된 .NET 스레드 풀에서 사용할 수 있는 스레드가 충분하지 않으면 MSMQ 어댑터 수신 위치에서는 스레드 부족으로 인해 문서를 처리하지 못합니다.
해결 방법
호스트 instance .NET 스레드 풀에서 사용 가능한 스레드 수를 늘리려면 어댑터 성능에 영향을 주는 구성 매개 변수 항목의 호스트에 대한 CLR 호스팅 스레드 값의 단계를 수행합니다.
MSMQ 수신 처리기에 바인딩된 각 MSMQ 수신 위치에는 .NET 스레드 풀의 스레드가 필요하므로 MinIOThreads 및 MinWorkerThreads 를 수신 처리기에 바인딩된 MSMQ 수신 위치 수보다 크거나 같은 값으로 설정합니다. 따라서 MaxIOThreads 및 MaxWorkerThreads 의 값을 수신 처리기에 바인딩된 MSMQ 수신 위치 수 * 2와 같은 값으로 설정하여 헤드룸을 허용합니다.
DWORD 항목 | 권장되는 값 |
---|---|
MaxIOThreads | MSMQ 어댑터 수신 처리기에 바인딩된 MSMQ 수신 위치의 수 * 2 |
최대작업자스레드 | MSMQ 어댑터 수신 처리기에 바인딩된 MSMQ 수신 위치의 수 * 2 |
MinIOThreads | MSMQ 어댑터 수신 핸들러에 바인딩된 MSMQ 수신 위치의 수 |
MinWorkerThreads | MSMQ 어댑터 수신 핸들러에 바인딩된 MSMQ 수신 위치의 수 |
이러한 권장 값은 호스트 인스턴스에서 실행 중인 다른 어댑터 핸들러 또는 오케스트레이션에 사용되는 스레드를 팩터링하지 않으므로 핸들러 또는 오케스트레이션에 따라 값을 알맞게 늘려야 합니다.
MSMQ 어댑터 수신 위치가 활성화된 후 바로 종료됩니다.
문제
MSMQ 수신 위치가 활성화된 후 바로 종료됩니다.
원인
이 문제는 메시지 큐 서비스의 로컬 비클러스터형 인스턴스가 MSMQ 수신 처리기의 호스트 인스턴스가 실행 중인 컴퓨터에서 실행되고 있지 않은 경우 발생할 수 있습니다.
해결 방법
MSMQ 수신 처리기의 호스트 인스턴스가 실행 중인 컴퓨터에서 메시지 큐 서비스를 시작합니다. MSMQ 어댑터 수신 처리기를 사용하려면 메시지 큐 서비스의 클러스터형 서비스가 동일한 컴퓨터에서 실행되고 있더라도 메시지 큐 서비스의 로컬 인스턴스가 실행 중이어야 합니다.
호스트 인스턴스에 대한 서비스를 중지하려고 하면 SC 도구에서 오류가 발생합니다.
문제
SC 도구(Sc.exe)를 사용하여 BizTalk 호스트 인스턴스에 대한 서비스를 종료하려고 하면 다음과 유사한 오류 메시지가 표시됩니다.
ControlService FAILED 1053:
서비스가 적절한 시간 내에 시작 또는 제어 요청에 응답하지 않았습니다.
이 오류 메시지가 표시되면 BizTalk 호스트 인스턴스에 대한 서비스가 중지됩니다. 그러나 SC 도구가 서비스를 종료하려면 2분 이상 소요될 수 있습니다.
이 문제는 BizTalk Server Microsoft 메시지 큐 수신 위치를 사용할 때 발생합니다.
또는 다음과 유사한 오류 메시지가 시스템 로그에 기록될 수 있습니다.
이벤트 유형: 오류
이벤트 원본: 서비스 제어 관리자
이벤트 범주: 없음
이벤트 ID: 7011
설명:
BTSSvc$BizTalkServerApplication 서비스에서 트랜잭션 응답을 기다리는 시간 제한(30000밀리초)
해상도
이제 Microsoft에서도 지원 핫픽스를 제공합니다. 그러나 이 핫픽스는 이 문서에서 설명하는 문제만 수정하도록 제작되었으므로 이 핫픽스는 이 특정 문제가 발생하는 시스템에만 적용하십시오. 또한 이 핫픽스는 추가 테스트를 거쳐야 할 수 있습니다. 따라서 해당 문제로 인해 심각한 영향을 받고 있는 것이 아니면 이 핫픽스를 포함하는 다음 서비스 팩을 사용하는 것이 좋습니다.
이 문제를 해결하려면 Microsoft 온라인 고객 서비스에 요청하여 핫픽스를 받으십시오.
참고
다른 문제가 발생하거나 문제 해결이 필요한 경우 별도의 서비스 요청을 만들어야 할 수 있습니다. 이 특정 핫픽스로 해결할 수 없는 문제나 질문을 지원하기 위해서는 통상적으로 지원 비용이 부과됩니다.