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AKS Edge Essentials의 일반적인 문제 해결

이 문서에서는 AKS Edge Essentials를 사용할 때 발생하는 문제에 대한 솔루션을 찾는 방법을 설명합니다. 알려진 문제 및 오류는 기능 영역별로 구성됩니다. 이 문서에 제공된 링크를 사용하여 해결 방법 및 해결 방법을 찾을 수 있습니다.

지원 요청 열기

Azure Portal을 사용하여 AKS Edge Essentials에 대한 지원을 받거나 지원 요청을 여는 방법에 대한 자세한 내용은 지원 문서 가져오기를 참조하세요.

배포 문제

신뢰할 수 없는 게시자 문제

오류 메시지: "신뢰할 수 없는 이 게시자에서 소프트웨어를 실행하시겠습니까? ....."

해결 방법: PowerShell 실행 정책을 RemoteSigned업데이트합니다.

# Get the execution policy on the system
Get-ExecutionPolicy
# Set the execution policy for this process only
if ((Get-ExecutionPolicy) -ne "RemoteSigned") { Set-ExecutionPolicy -ExecutionPolicy RemoteSigned -Scope Process -Force }

디스크 공간이 부족하면 이전에 캐시된 컨테이너 이미지가 삭제됩니다.

노드가 디스크 공간이 부족하면 미리 로드된 이미지 중 일부는 런타임에 containerd 의해 수집되는 가비지입니다. 이 경우 먼저 일부 디스크 공간을 확보한 다음 다음 명령을 실행하여 캐시된 이미지를 다시 끌어오세요.

    Invoke-AksEdgeNodeCommand -NodeType Linux -command "sudo /path/to/script/reimport-ci.sh

이 스크립트는 누락된 이미지를 확인하고 필요에 따라 이미지를 다시 가져옵니다.

Azure Arc 연결

  1. 문제: Disconnect-AksEdgeArc 클러스터에서 Pod를 제거하지 않습니다.

    해결 방법: Pod가 정리되지 않은 경우 다음 명령을 실행하여 다시 연결하기 전에 기존 Azure Arc 관련 리소스를 수동으로 정리합니다.

    kubectl delete ns azure-arc
    kubectl delete clusterrolebinding azure-arc-operator
    kubectl delete secret sh.helm.release.v1.azure-arc.v1
    
  2. 문제: Azure Arc 연결은 프록시 환경에서 작동하지 않습니다.

    해결 방법: 인터넷 옵션 > 연결 LAN 설정에 따라 > 사용하도록 설정할 수 있습니다.

    인터넷 옵션을 보여 주는 스크린샷

PodDisruptionBudget(PDB) 리소스를 사용하여 AKS Arc 클러스터를 완전히 삭제할 수 없음

이 알려진 문제에 대한 자세한 내용은 AKS Arc 설명서의 PDB 리소스를 사용하여 AKS Arc 클러스터를 완전히 삭제할 수 없음을 참조하세요.

오프라인 배포

nodeagent 인증서를 가져오는 데 실패했습니다. 찾을 수 없음

네트워크 어댑터 구성을 확인합니다. 배포하는 동안 AKS Edge Essentials에는 사용하도록 설정되고 올바른 IP 주소, 서브넷 및 기본 게이트웨이가 있는 어댑터가 필요합니다. 이러한 값은 DHCP 환경에서 자동으로 채워집니다. 수동으로 설정하는 경우 세 가지가 모두 설정되어 있는지 확인합니다. 대부분의 경우 기본 게이트웨이가 설정되지 않아 이 오류가 발생합니다.

Kubernetes

Kube-vip Pod가 지속적으로 다시 시작됩니다.

일부 시나리오 에서는 kube-vip Pod가 반복되고 계속 다시 시작됩니다.

유효성 검사

발생하는 시나리오가 이 문서에 설명된 것과 동일한 문제인지 확인하려면 다음 명령을 실행하여 kube-system 네임스페이스의 kube-vip Pod에 많은 수의 다시 시작이 있는지 확인합니다.

kubectl get pods –n kube-system

원인

kube-vip Pod가 지속적으로 다시 시작될 수 있는 몇 가지 다른 이유가 있습니다. 이러한 원인은 다음과 같습니다.

  • Azure VM을 사용할 때 SSD 디스크로 지원되지 않는 OS 디스크 또는 프리미엄 SSD 디스크를 사용합니다. 여기에서 하드웨어 요구 사항을 검토할 수 있습니다.
  • 디스크 대기 시간이 너무 깁니다. 디스크 대기 시간이 10ms보다 크면 요청 시간 제한, 리더 손실 및 잠재적인 클러스터 불안정이 발생할 수 있습니다. 여기에서 etcd에 대한 하드웨어 요구 사항을 검토할 수 있습니다.

해결

이 문제를 완화하려면 기본 스토리지 인프라를 검토하여 etcd 및 AKS Edge Essentials의 성능 요구 사항을 충족하는지 확인합니다. 또한 프리미엄 SSD 지원 스토리지를 사용하거나 성능을 위해 스토리지 구성을 최적화하는 것이 좋습니다.

다음 단계

AKS 엣지에센셜 개요