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FIM 2010 Troubleshooting: Update 2 Fails Immediately - DetectServiceAccount

 


Problem Statement

You are attempting to install Update 2 for FIM 2010 for the FIM Service and it immediately goes to the last page with no error message.  The installation screen states that the install finished prematurely.

You capture a Windows Installer Verbose log file of the installation.  In the log file, you find the following information as to why it failed.  You will see DetectServiceAccount.  This indicates that the installation is failing while firing the DetectServiceAccount Custom Action. 

Windows Installer Verbose Log File Information

MSI (c) (80:0C) [13:08:03:552]: Invoking remote custom action. DLL: %userprofile%\AppData\Local\Temp\2\MSI762F.tmp, Entrypoint: DetectServiceAccount

CustomAction DetectServiceAccount returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

MSI (c) (80:0C) [13:08:03:649]: Closing MSIHANDLE (4) of type 790542 for thread 3360

Action ended 13:08:03: DetectServiceAccount. Return value 3.

 

Cause

The service is running with a UPN logon rather than DOMAIN\UserName.


Resolution

  1. On the FIM Service Machine, open the Services.mmc
  2. Find the Forefront Identity Manager Service and open the properties
  3. Select Logon Tab
  4. Replace the UPN information with a DOMAIN\UserName format
  5. Click Ok
  6. Restart the Forefront Identity Manager Service
  7. Execute the installation

 


See Also