Your message wasn’t delivered because the recipient’s mailbox is quarantined
Issue:
User cannot access mailbox & sending email to this type of mailbox will receive an NDR stating “Your message wasn’t delivered because the recipient’s mailbox is quarantined”
Cause:
The mailbox is a potential threat to the health of the Information store and has been quarantined. There are several types of events for which the Exchange store tags a mailbox as a potential threat:
If a thread doing work for that mailbox fails
If there are more than five threads in that mailbox that haven’t made progress for a long time
Detail:
This is called Poison mailbox issue, any mailbox identified as potential threat to the mailbox database will be quarantined by exchange servers, since Office365 multi tenant environment we cannot do a manual process to fix this. However by default exchange resets Quarantined mailboxes in 24 hrs after the quarantine flag is set.
How to Find the status:
Run this command to retrieve Quarantine status of the mailbox:
Get-MailboxStatistics UserName | fl *Quarantine*
IsQuarantined : True
QuarantineDescription :
QuarantineLastCrash :
QuarantineEnd : 6/18/2015 3:57:37 PM
QuarantineFileVersion :
Reference Poison Mailbox: https://technet.microsoft.com/library/bb331958.aspx