Troubleshooting FIM: sync-rule-invalid-xml-attribute-flow
PROBLEM STATEMENT
Running a synchronization on a management agent, you receive an error “sync-rule-invalid-xml-attribute-flow”.
TROUBLESHOOTING STEPS:
- Full Import (Stage Only) on the FIM Service Management Agent
- Full Synchronization on the FIM Service Management Agent
CAUSE
In doing the Full Synchronization on the FIM Service Management Agent, I noticed that same error “sync-rule-invalid-xml-attribute-flow” appeared on a Synchronization Rule.
Investigation into the error “sync-rule-invalid-xml-attribute-flow” found the following error:
Synchronization Rule Flow: <import-flow><src><attr>Manager</attr></src><dest>manager</dest><scoping></scoping></import-flow>
Synchronization Rule Error: Direct mapping has a type mismatch between the source attribute and the destination attribute.
- The manager attribute in the Source Management Agent was defined as a string data type.
- The manager attribute in the Metaverse on the Person object was defined as a Reference(DN) data type.
This would create a type mismatch error!
RESOLUTION
- In the Source Management Agent, change the data type on the Manager attribute to a Reference (DN).
- Modify the Synchronization Rule in question
- In the FIM Portal, select Administration and then Synchronization Rules
- Select the Synchronization Rule in question
- Click on the Inbound Attribute Flow
- Find the reference for Manager => Manager
- Delete the reference for Manager => Manager
- Click ok, and then Submit the information
- Go to the Synchronization Service Engine
- Select the FIM Service Management Agent on the Management Agents Tab
- Execute a Full Import (Stage Only) – [Actions menu > Run > Full Import (Stage Only) run profile]
- Execute a Full Synchronization on the FIM Service Management Agent
Note
if you are familiar with working with Preview, you can Commit Preview the Synchronization Rule
** **
-
- Go back to the Synchronization Rule
- Click on Inbound Attribute Flow
- Add a new attribute flow for Manager => Manager
- Click ok and then Submit the information
- Go to the Synchronization Service Engine
- Select the FIM Service Management Agent on the Management Agents Tab
- Execute a Full Import (Stage Only) – [Actions menu > Run > Full Import (Stage Only) run profile]
- Execute a Full Synchronization on the FIM Service Management Agent
Note
if you are familiar with working with Preview, you can Commit Preview the Synchronization Rule