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TFS Reporting database backup fails with TFS Backup tool

Issue Details:

Reportserver and Reportservertempdb backup with TFS backup tool fails with the following errors.

TF400981: Failed to backup the Reporting Services encryption key. You can try using RSKEYMGMT command to backup the encryption key

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Cause

It was due to the implementation of firewall infrastructure which did not allow WMI Queries which is being used by TFS backup tool in the background.

Troubleshooting:

  1. We took backup of encryption key as mentioned in the warning message but this did not help.
  2. So we took a debug view trace and got the following COM exception:00000799             157.66336060     [4692] [Verbose@14:25:37.059] Caught COMException attemping WMI connect(). The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)            00000800             178.42982483     [4692] [Verbose@14:25:58.106] Caught COMException attemping WMI connect(). The RPC server is unavailable. (Exception from HRESULT: 0x800706BA) 00000798             136.35156250     [4692] [Verbose@14:25:16.028] Caught COMException attemping WMI connect(). The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)           
  3. This helped in identifying that this issue is mainly due to blocking of the WMI requests in the background.
  4. We checked and found that the Microsoft firewall was off but on digging deeper found that there was a third party firewall hardware available in this case which blocked all requests.

Resolution:

  1. WMI uses ports 135 and also the range of ports between 49152-65535.
  2. We opened port 135 and 49154 which was identified by network monitoring and this resolved the backup issue. It might happen that some other ports from the mentioned range might be used by WMI where this solution might not work. In that case the recommended approach is to make sure that WMI uses only one port by configuring it as mentioned in the following article: https://msdn.microsoft.com/en-us/library/bb219447(v=vs.85).aspx

 Written by: Deepak Mishra, Support Engineer

 Reviewed by: Nitish Nagpal, Support Escalation Engineer