Google Chrome ブラウザで追加設定や変更を行うが設定内容が反映されない
みなさん、こんにちは。
Microsoft Dynamics CRM は、Internet Explorer (IE) や FireFox (FF)、Chrome ブラウザをサポートしております。最近、Google Chrome を使った場合の動作についてよくお問い合わを頂いてります。Internet Explorer (IE) や FireFox (FF) では発生しないが、Chrome で発生する事象があります。
[現象]
- Google Chorme ブラウザを使用し、ソリューションにコンテンツの追加出来ない
- ワークフローの設定変更を行うが、変更が反映されない
- フォームにサブグリッドが追加することが出来ない
等、追加設定や変更を行うことが出来ない問題が発生します。
[環境]
- Microsoft Dynamics CRM 2011
- Microsoft Dynamics CRM 2013
- Google Chrome 37 以降
[原因]
Google Chrome のアップデート (37) により、JavaScriptのshowModalDialog()メソッドがデフォルトで機能停止されたため、このメソッドを使用してCRMでダイアログ画面から値をセットしたり値を取得したりすることができなくなりました。Microsoft Dynamics CRM 製品ではこのメソッドは多く使われており、色々な箇所で設定反映や変更が出来ない問題が発生すると考えられます。
詳細は、以下 Knowledge Base (KB) を参照して下さい。(英語のみ)
https://support.microsoft.com/kb/3000002
[解決方法]
現時点 (10月中旬) 、Microsoft Dynamics CRM 製品側での対応は検討中です
[回避策]
KB には英語の回避策が記載されておりますが、わかりやすく日本語の画面ショット付き手順で説明します。
以下のリンクをクリックし、「名前を付けて保存」で zip ファイルを適当な場所に保存します
保存した zip ファイルを解凍します
「ローカルグループポリシーエディター」画面の「コンピューターの構成」か「ユーザーの構成」のいずれか一方を右クリックします。ご使用になられる環境に合わせてお選びください。(以下「コンピューターの構成」を例にとって説明します)
手順2 で保存・解凍した「policy_templates」フォルダの中の\windows\adm\jaにある「chrome.adm」をクリックし、「開く」をクリックします
「閉じる」をクリックします
手順 5 の「ローカルグループポリシーエディター」画面にもどりますので「管理用テンプレート」>「従来の管理用テンプレート(ADM)」>「Google」>「Google Chrome」の順に開きます。
(「Google Chrome―デフォルト設定・・・・」の方ではありませんのでご注意ください)
適用」をクリック後「OK」をクリックします
「ローカルグループポリシーエディター」画面を閉じて、PCを再起動します
「ホスト名のパターン」にCRM組織のURL(https://xxxx.crm5.dynamics.com)を入力し、「動作」が「許可」になっているのを確認してから「完了」をクリックします
Google Chrome を再起動します
- 野田良二