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Azure Lab Services 연결 문제 해결

Important

Azure Lab Services는 2027년 6월 28일에 사용 중지됩니다. 자세한 내용은 사용 중지 가이드를 참조하세요.

이 문서에서는 Azure Lab Services의 일반적인 연결 문제를 해결하는 방법에 대한 지침을 제공합니다.

Important

Azure Lab Services는 랩에 대한 일부 지원 리소스에 직접 액세스할 수 없는 관리형 제품입니다. 이 문제는 Azure Virtual Machine의 RDP 연결 문제 해결 등의 다른 Azure VM 문제 해결 가이드를 활용하는 기능에 영향을 줍니다.

연결 속도 저하

증상

  • 느린 RDP(원격 데스크톱 프로토콜) 연결

원인

  • 특정 랩 VM
  • VPN 사용
  • 네트워크의 방화벽
  • 특정 ISP(인터넷 서비스 공급자)

해결

  • RDP 연결 속도 정량화

    PsPing 유틸리티를 사용하여 컴퓨터에 대한 응답 시간을 측정할 수 있습니다. 랩 사용자에게 최상의 RDP 환경을 보장하는 방법 블로그에 단계가 포함되어 있습니다.

  • 문제의 범위 확인:

    • 특정 컴퓨터인지 여부
    • 사용 중인 VPN이 있는지 여부
    • 특정 네트워크에서 속도가 느린지 여부
    • 네트워크에 방화벽이 있는지 여부
    • 특정 ISP에서 속도가 느려지는지 여부
특정 컴퓨터

클라이언트 환경의 설정을 조정하여 전송되는 데이터의 양을 줄입니다.

VPN 사용

적절한 문제 해결 단계는 VPN을 끈 다음, 연결 속도가 향상되는지 확인하는 것입니다. VPN이고 필요한 경우, RDP 또는 SSH 연결이 '통과된' 연결이 되도록 하는 VPN 설정 및 구성이 먼 지역으로 라우팅되거나 잘못 라우팅되지 않는지 검토합니다.

특정 네트워크 또는 방화벽

네트워크는 엔터프라이즈 수준 네트워크에서 학생의 홈 라우터/Wi-Fi 조합에 이르는 Azure Lab Services에 대한 연결에 영향을 줄 수 있습니다. 예를 들어 학생의 홈 라우터에는 RDP/SSH 연결을 차단하거나 제한하는 기본 제공 방화벽이 있을 수 있습니다. 네트워크에서 방화벽이 사용하도록 설정되어 있는지, RDP/SSH 연결을 제한하도록 구성되었는지 확인합니다.

특정 ISP(인터넷 서비스 공급자)

연결할 ISP가 여러 개 있는 것은 일반적이지 않습니다. 특정 네트워크에서 속도가 느려지고 다른 옵션이 탐색된 경우 ISP에 문의하여 RDP/SSH 연결에 대한 제한이 있는지 확인할 수 있습니다.

원격 컴퓨터에 연결할 수 없음

증상

  • 학생들에게 "원격 데스크톱에서 원격 컴퓨터에 연결할 수 없습니다... 원격 컴퓨터가 켜져 있고 네트워크에 연결되어 있으며 원격 액세스가 사용하도록 설정되었는지 확인합니다." 메시지가 표시됩니다.

    '원격 데스크톱이 원격 컴퓨터에 연결할 수 없습니다... 원격 컴퓨터가 켜져 있고 네트워크에 연결되어 있고 원격 액세스가 사용하도록 설정되어 있는지 확인합니다'라는 오류를 표시하는 원격 데스크톱 연결용 모달

원인

  • 학생이 연결하려는 가상 머신이 실행되고 있지 않음
  • 랩 VM이 여전히 시작 중일 수 있음
  • 유휴 설정은 랩 VM 연결에 영향을 줄 수 있음

해결

랩 포털을 열고 가상 머신이 실행 중으로 표시되는지 확인합니다. 실행되지 않는 경우 학생은 랩 포털에서 가상 머신을 시작할 수 있습니다. 머신이 완전히 실행되는 데 2~5분 정도 걸릴 수 있습니다.

랩 자동 종료 설정을 조정하여 학생 연결 환경이 개선될 수 있습니다. 가상 머신을 켜고 끄는 데 시간이 걸리므로 설정을 조정하여 머신이 상태를 변경하는 동안 학생이 연결을 시도할 가능성이 줄어듭니다. 자동 종료 설정은 비용 절감 전략의 일부이지만 학생 환경을 개선하기 위해 조정해야 할 수도 있습니다.

  • 유휴 가상 머신 종료: 기간이 너무 짧으면 학생이 컴퓨터를 시작한 다음, 연결할 때 또는 학생이 활성 상태가 아닌 경우(예: 교실 수업) 가상 머신이 종료될 수 있습니다.
  • 사용자가 연결을 끊을 때 가상 머신 종료: 시간 지연이 너무 작은 경우 실수로 연결이 끊기면 종료가 시작되는 문제가 발생할 수 있습니다. 학생들은 연결하려면 가상 머신을 다시 시작해야 합니다.
  • 사용자가 연결하지 않을 때 가상 머신 종료: 학생이 일정 시간 후에 가상 머신에 연결하지 않고 기간이 너무 짧으면 가상 머신이 종료됩니다. 타이밍은 학생들이 가상 머신을 직접 시작하거나 랩에서 일정을 사용하는 경우 영향을 줄 수 있습니다. 유휴 설정을 더 긴 기간으로 변경하는 것은 옵션이지만 잠재적인 비용에 영향을 미칩니다. 일정을 사용하는 경우 클래스 시간이 시작될 때 가상 머신을 더 가깝게 시작할 수 있습니다.

아웃바운드 연결이 제한됨

증상

  • 방화벽, 스위치, 라우터 또는 기타 네트워크 어플라이언스가 RDP/SSH(3389/22) 포트를 차단하거나 제한하는 경우 네트워크가 간섭 지점이 될 수 있습니다.

원인

  • 아웃바운드 RDP/SSH 연결을 제한하는 학교, 대학, 엔터프라이즈 또는 홈 네트워크의 로컬 방화벽
  • 최신 라우터, 특히 WiFi 6에는 RDP/SSH 연결을 차단하거나 제한하는 기본 동작이 있습니다.
  • 운영 체제에서 아웃바운드 RDP/SSH 연결 제한

해결

RDP/SSH 제한을 제거하거나 랩 공용 IP 주소에 대한 예외를 추가하는 것이 좋습니다. 이러한 주소는 방화벽 또는 라우터에 대한 허용 목록에 추가될 수 있습니다.

관리자 변경 후 랩 연결 문제

증상

  • 학생은 네트워크 구성을 포함하여 시스템을 변경할 수 있는 랩 VM의 관리자입니다.

원인

  • 동적 IP로 지정하지 않고 고정 IP로 IP 주소 업데이트
  • DHCP 사용 안 됨(IP 주소 자동 가져오기 방지)
  • DNS 서버 지정
  • 로컬 사용자 그룹 및 권한 업데이트

해결

컴퓨터 종료 시 네트워킹을 자동으로 설정하는 스크립트를 사용하여 랩 템플릿을 설정할 수 있습니다. 그렇지 않으면 학생 또는 교사가 랩 VM을 이미지로 다시 설치해야 정상 상태로 돌아갑니다.

사용자 지정 DNS가 필요한 경우 고급 네트워킹을 사용하고 가상 네트워크에서 사용자 지정 DNS 서버를 지정합니다.

랩 VM이 나가는 VPN을 통해 연결할 수 없음

증상

  • 학생이 학생 VM에서 VPN 연결을 사용하려고 하면 VPN이 연결되지 않음

원인

  • VPN의 Azure Lab Services 네트워크 구성에 문제가 있음

해결

질문이 있거나 도움이 필요한 경우 지원 요청을 생성하거나Azure 커뮤니티 지원에 문의하세요.

Azure 지원 요청을 만들 때 요청 세부 정보에 다음 정보를 제공하여 문제 해결을 가속화합니다.

  • 랩 플랜 ID. Azure Portal에서 랩 플랜을 선택하고 속성 페이지로 이동합니다.
  • 랩 ID. Azure Portal에서 랩을 선택하고 속성 페이지로 이동합니다. 또는 Azure Lab Services 웹 사이트에서 랩의 URL을 선택합니다.
  • 문제가 발생한 대략적인 시간입니다.
  • Azure 활동 로그에 나열된 모든 오류입니다. Azure Portal에서 랩 플랜 또는 랩을 선택하고 활동 로그 페이지로 이동합니다. 활동 로그를 보고 다운로드하는 방법을 알아봅니다.

배포 후에 랩 VM에 연결할 수 없음

증상

  • 랩에 오류가 있는 경우 컴퓨터 연결이 제대로 작동하지 않을 수 있음

원인

  • Azure 활동 로그는 가장 포괄적인 이벤트 및 결과 목록입니다.

해결

활동 로그는 랩이 있는 리소스 그룹에서 필터링할 수 있습니다. 로그에서 이벤트를 사용할 수 있는 데 몇 분 정도 걸릴 수 있습니다. 이러한 이벤트 로그에는 문제 해결에 사용할 수 있는 자세한 정보가 포함되어 있으며 지원 티켓을 만들어야 하는 경우 포함해야 합니다.

사용자 이름 및 암호로 로그인할 수 없음

증상

  • 사용자 이름 및 암호를 사용하여 랩 VM에 연결할 수 없음
  • '자격 증명이 작동하지 않음' 오류 메시지가 표시됩니다.

원인

  • 잘못된 자격 증명을 사용하는 학생
  • 학생이 암호를 잊어버림
  • 암호가 Azure Compute Gallery 이미지와 연결됨
  • 컴퓨터가 손상됨

해결

잘못된 자격 증명을 사용하는 학생

학생이 랩 VM에 올바른 사용자 이름과 암호를 사용하고 있는지 확인합니다. "모든 가상 머신에 동일한 암호 사용"을 사용하도록 설정하고 랩을 만든 경우 사용자 이름과 암호는 각 학생에 대해 동일해야 합니다.

학생이 암호를 잊어버림

사용자 지정 암호가 있는데 잊어버린 경우 학생은 랩에서 머신의 암호를 재설정할 수 있습니다. 또한 학생은 컴퓨터를 머신을 이미지로 다시 설치할 수 있지만 모든 사용자 데이터는 삭제되고 검색할 수 없습니다.

다른 학생이 공통 랩 사용자 이름 및 암호를 사용하여 로그인할 수 없고 기존 사용자 지정 이미지를 사용하여 랩을 만든 경우 이 문제는 알려진 제한 사항으로 인해 발생할 수 있습니다. 해결 방법은 이미지를 만들거나 암호를 재설정할 때 사용자 이름과 암호를 사용하는 것입니다.

컴퓨터가 손상됨

잘못된 작업자가 학생 암호를 가짜로 변경하는 상황이 있습니다. 학생은 암호를 재설정하여 머신에 대한 액세스 권한을 다시 얻을 수 있지만 이러한 상황이 발생할 가능성을 줄이는 다음과 같은 몇 가지 제안 사항이 있습니다.

  • 랩을 만들 때 일반 암호를 사용하지 말고 동일한 암호 사용 옵션을 선택 취소합니다. 개별 특정 암호를 사용하면 암호가 손상된 경우 해당 범위가 줄어듭니다.
  • 강력한 암호 사용 및 암호 보호
  • 수업에 있는 학생만 컴퓨터에 액세스할 수 있도록 랩에 대한 액세스를 제한합니다. 기본적으로 랩은 제한됩니다.
원격 데스크톱 게이트웨이

드물지만 학생이 사용하는 원격 데스크톱 클라이언트에는 원격 데스크톱 게이트웨이를 구성할 수 있습니다. 이 경우 학생 VM에 연결하기 전에 먼저 게이트웨이 자격 증명을 입력해야 합니다(게이트웨이에 인증하기 위해).

고급 네트워킹 문제 해결

일부 문제 해결 시나리오는 고급 네트워킹을 사용하는 랩에만 적용됩니다.

네트워크 보안 그룹 누락

고급 네트워킹으로 구성된 랩 플랜의 경우 첫 번째 확인 사항 중 하나는 랩 서비스 네트워크 서브넷에 네트워크 보안 그룹이 연결되어 있는지 확인하는 것입니다. 이를 통해 RDP/SSH 연결을 허용할 수 있습니다. 네트워크 보안 그룹이 없으면 가상 머신(템플릿 VM 및 학생 VM)에 대한 모든 연결이 차단됩니다.

Azure 가상 머신 RDP 문제 해결 사용

고급 네트워킹으로 구성된 랩에는 고유한 문제 해결 기술이 있습니다. 고급 네트워킹을 사용하면 랩 플랜이 연결된 가상 네트워크에 직접 연결되어 있는 Azure Virtual Machine을 만들어 더 많은 문제를 해결할 수 있습니다. 이 Azure VM(Azure Lab Services 외부)을 사용하면 Azure 내 연결 문제 해결사를 포함하여 Azure Virtual Machine RDP 문제 해결 가이드를 사용하여 네트워크가 올바르게 구성되었는지 확인할 수 있습니다.

NSG 규칙이 RDP/SSH 연결을 차단함

이전 섹션에서 가상 네트워크에 직접 연결된 Azure VM을 사용하여 Azure Portal에서 직접 가상 머신 네트워크 연결 문제를 진단할 수 있습니다. 보안 규칙을 통한 RDP/SSH 연결의 차단 또는 제한은 네트워크 보안 그룹을 사용하여 서브넷에서 또는 Azure Virtual Network Manager를 사용하여 수행할 수 있습니다. 규칙의 전체 목록을 확인하는 가장 쉬운 방법은 Azure Virtual Machine 네트워크 유효 보안 규칙을 통하는 것입니다.

기본 사용자 정의 경로(경로 테이블 문제)

고급 네트워킹을 사용하면 경로 테이블 수정을 포함하여 필요에 따라 네트워크를 사용자 지정할 수 있습니다. 사용자 정의 경로 테이블은 트래픽을 적절한 대상으로 전달합니다. 다른 로컬 주소에 바인딩되지 않은 트래픽을 인터넷으로 전송하는 특수 경로인 "인터넷 경로"(0.0.0.0/0)가 있습니다. Azure Lab Services 고급 네트워킹은 0.0.0.0/0 경로에 대한 '다음 홉'을 인터넷을 제외한 모든 경로로 업데이트하는 것을 지원하지 않습니다. 이 경로를 특정 IP 주소로 변경하면(예: 아웃바운드 인터넷 트래픽을 방화벽 또는 다른 네트워크 어플라이언스로 전송) 비대칭 라우팅 문제가 발생하여 랩에 대한 연결이 끊어집니다. 디버깅할 때 사용자 지정 경로 테이블에 대한 검사 기본 경로가 인터넷에 0.0.0.0/0으로 설정되어 있는지 확인합니다.

추가 문제 해결

위의 단계를 수행한 후에도 여전히 문제가 발생하는 경우 추가 문제 해결을 위해 더 많은 데이터를 수집해야 할 수 있습니다. 여기에는 가상 머신의 로그, 네트워크 추적 데이터 또는 기타 관련 정보가 포함될 수 있습니다.

질문이 있거나 도움이 필요한 경우 지원 요청을 생성하거나Azure 커뮤니티 지원에 문의하세요.

Azure 지원 요청을 만들 때 요청 세부 정보에 다음 정보를 제공하여 문제 해결을 가속화합니다.

  • 랩 플랜 ID. Azure Portal에서 랩 플랜을 선택하고 속성 페이지로 이동합니다.
  • 랩 ID. Azure Portal에서 랩을 선택하고 속성 페이지로 이동합니다. 또는 Azure Lab Services 웹 사이트에서 랩의 URL을 선택합니다.
  • 문제가 발생한 대략적인 시간입니다.
  • Azure 활동 로그에 나열된 모든 오류입니다. Azure Portal에서 랩 플랜 또는 랩을 선택하고 활동 로그 페이지로 이동합니다. 활동 로그를 보고 다운로드하는 방법을 알아봅니다.