バグ チェック 0x74: BAD_SYSTEM_CONFIG_INFO
BAD_SYSTEM_CONFIG_INFO バグ チェックの値は 0x00000074 です。 このバグチェックは、レジストリにエラーがあることを示しています。
重要
この記事は、プログラマー向けです。 コンピューターを使用中に、ブルー スクリーン エラーが表示された場合は、「ブルー スクリーン エラーのトラブルシューティング」を参照してください。
BAD_SYSTEM_CONFIG_INFO パラメーター
パラメーター | 説明 |
---|---|
1 |
予約済み |
2 |
予約済み |
3 |
予約済み |
4 |
NT ステータス値/コード (使用可能な場合) |
原因
BAD_SYSTEM_CONFIG_INFOバグ チェックは、SYSTEM ハイブが破損している場合に発生します。 しかし、ブートローダーはハイブを読み込みする際に、ハイブが壊れていないかチェックするため、このような破損が起こる可能性はほとんどありません。
このバグチェックは、重要なレジストリ キーと値が不足している場合にも発生する可能性があります。 ユーザーがレジストリを手動で編集した場合、またはアプリケーションまたはサービスによってレジストリが破損した場合、キーと値が欠落している可能性があります。
パラメーター 4 で返される NT 状況値を調べることで、追加情報を提供することができます。リストの NTSTATUS 値 を参照してください。
解決方法
Windows システム イベント ログを調べて、レジストリ関連のエラー イベントがあるかどうかを確認します。 イベントに、エラーが発生したハイブまたは特定のキーが一覧表示される場合。
!analyze デバッグ拡張コマンドは、バグ チェックに関する情報を表示し、根本原因の特定に役立ちます。
BAD_SYSTEM_CONFIG_INFO (74)
Can indicate that the SYSTEM hive loaded by the osloader/NTLDR
was corrupt. This is unlikely, since the osloader will check
a hive to make sure it isn't corrupt after loading it.
It can also indicate that some critical registry keys and values
are not present. (i.e. somebody used regedt32 to delete something
that they shouldn't have) Booting from LastKnownGood may fix
the problem, but if someone is persistent enough in mucking with
the registry they will need to reinstall or use the Emergency
Repair Disk.
Arguments:
Arg1: 0000000000000002, (reserved)
Arg2: ffffd481054b49f0, (reserved)
Arg3: 0000000000000004, (reserved)
Arg4: ffffffffc000014c, usually the NT status code.
!analyze によって返されるすべての情報を確認して、エラーについて学習します。
!error 拡張機能を使用して、パラメーター 1 の例外コードに関する情報を表示します。
2: kd> !ERROR ffffffffc000014c
Error code: (NTSTATUS) 0xc000014c (3221225804) - {The Registry Is Corrupt} The structure of one of the files that contains Registry data is corrupt, or the image of the file in memory is corrupt, or the file could not be recovered because the alternate copy or log was absent or corrupt.
レジストリに存在するハイブなど、レジストリに関する情報を表示するには !reg 拡張機能を使用します。
!reg hivelist
-------------------------------------------------------------------------------------------------------------------------------------------------------
| HiveAddr |Stable Length| Stable Map |Volatile Length| Volatile Map |MappedViews|PinnedViews|U(Cnt)| BaseBlock | FileName
-------------------------------------------------------------------------------------------------------------------------------------------------------
| ffff95077ea24000 | 1000 | ffff95077ea24588 | 0 | 0000000000000000 | 0| ffff95077ea31000 | <NONAME>
| ffff95077ea3e000 | 12d3000 | ffff95077ea49000 | 21000 | ffff95077ea3e800 | 0| ffff95077ea40000 | SYSTEM
| ffff95077ea8f000 | 53000 | ffff95077ea8f588 | 9000 | ffff95077ea8f800 | 0| ffff95077ea91000 | <NONAME>
| ffff9507821c8000 | 7000 | ffff9507821c8588 | 0 | 0000000000000000 | 0| ffff9507821cc000 | kVolume2\EFI\Microsoft\Boot\BCD
| ffff95077f6ae000 | 685c000 | ffff95077f737000 | 6000 | ffff95077f6ae800 | 0| ffff95077f6b6000 | emRoot\System32\Config\SOFTWARE
-------------------------------------------------------------------------------------------------------------------------------------------------------
!reg openkeys コマンドを使用して、開いていたレジストリ キーを確認します。
2: kd> !reg openkeys
Hive: \REGISTRY\MACHINE\SYSTEM
===========================================================================================
Index 0: 00000000 kcb=ffffd805e303c728 cell=00000020 f=002c0100 \REGISTRY\MACHINE\SYSTEM
Index 1: db67f96d kcb=ffffd805e416ed18 cell=00bd0b40 f=00200080 \REGISTRY\MACHINE\SYSTEM\WPA\8DEC0AF1-0341-4B93-85CD-72606C2DF94C-7P-374
Index 3: db67ee93 kcb=ffffd805e30c5ab8 cell=00bc1550 f=00200080 \REGISTRY\MACHINE\SYSTEM\WPA\8DEC0AF1-0341-4B93-85CD-72606C2DF94C-7P-161
Index 4: f9909d96 kcb=ffffd805e44bd268 cell=00bf8f50 f=00200000 \REGISTRY\MACHINE\SYSTEM\CONTROLSET001\CONTROL\POWER\PROFILE\EVENTS\{54533251-82BE-4824-96C1-47B60B740D00}\{8BC6262C-C026-411D-AE3B-7E2F70811A13}
Index 5: e9dd6ce5 kcb=ffffd805e4180e48 cell=00812970 f=00200000 \REGISTRY\MACHINE\SYSTEM\DRIVERDATABASE
...
解説
ブルー スクリーンの原因の特定に関する一般的な情報については、バグ チェックのブルー スクリーン データの分析に関する記述を参照してください。
OS を正常に機能させるために十分なハード ドライブまたは SSD ストレージがあることを確認することをお勧めします。
システム ファイル チェッカー ツールで、Windows 上の破損を見つけることができます。 詳細については、「システム ファイル チェッカー ツールを使用して不足または破損しているシステム ファイルを修復する」を参照してください。
セーフ モードで起動してから、OS を正常に再起動してみてください。 再起動しても問題が解決しない場合、レジストリの損傷が大きすぎます。 次の手順を実行します。
- システム復元ポイントがある場合は、以前の復元ポイントに復元してみてください。
- PCを初期状態に戻します。
- インストール メディアを使用して、PC を復元またはリセットします。
- インストール メディアを使用して Windows を再インストールします。
詳しくは、「Windows 10 の回復オプション」をご覧ください。
このサポート記事では、次のバグ チェック コードについて説明します。 エラー 0x74: Bad_system_config_info