Active Directory 診断テンプレートでPerfmon.exeを実行してドメイン コントローラーでレポートを生成すると、レポート生成プロセスが応答しなくなる場合があります
この記事では、Active Directory 診断テンプレートを使用してレポートを生成するPerfmon.exeを実行すると、レポート生成プロセスの応答が停止する問題を解決するためのヘルプを提供します。
元の KB 番号: 971714
現象
Active Directory 診断テンプレートを使用してPerfmon.exeを実行して Windows Server ドメイン コントローラーにレポートを生成すると、プロセスが応答しなくなる可能性があります。
原因
この問題は、TraceRpt.exe ツールを実行している信頼性とパフォーマンス モニター (Perfmon.exe) コンソールが、レポート生成プロセス中に消費するメモリと CPU リソースが多すぎるために発生します。 Windows Server がビジー状態でリソースがない場合、レポート生成プロセスは応答を停止します。
解決方法
この問題を解決するには、同じサーバーの役割を持ち、ハードウェア リソースが十分にある別のコンピューターにファイルをコピーします。 次に、ファイルを使用してTraceRpt.exeを実行します。 これを行うには、次の手順を実行します。
[信頼性とパフォーマンス モニター ](Perfmon.exe) コンソールで、[データ コレクター セットをクリックし、System をクリックします。
[ Active Directory Diagnostics を右クリックし、[ Start] をクリックします。 ファイル収集プロセスは、Windows Server ドメイン コントローラーで開始されます。
レポートの状態が生成レポートに変わったらcollecting data for<time>** から、2 番目の Windows Server ドメイン コントローラーにファイルをコピーします。
Note
ファイルは、%systemdrive%\Perflogs\ADDS\ date レポート生成実行の場所にあります。 \*
"-df" スイッチは、Perfmon で生成される Microsoft 固有のカウント/レポート スキーマ ファイルを指定することです。 このファイル名は report.xsl という名前です。
ファイルを見つけて、2 番目の Windows Server ドメイン コントローラーのコマンド ラインで次のコマンドを実行します。
tracerpt *.blg *.etl -df *PerfmonSchemaFileName.xsl* -report *your_report.html* -f html **** ****
Windows Internet Explorer を使用して、生成された.html ファイルを表示します。