多数の I/O 操作を実行するコンピューターでボリューム シャドウ コピー サービスを使用する場合、ディスク ボリュームのオンライン化に時間がかかります
この記事では、ボリュームでボリューム シャドウ コピー サービスを有効にした後、ディスク ボリュームのオンライン化に時間がかかる問題の回避策について説明します。
元の KB 番号: 945058
重要
この資料には、レジストリの編集方法が記載されています。 レジストリを変更する前に必ずレジストリのバックアップを作成してください。 また、問題が発生した場合に備えて、レジストリの復元方法を理解しておいてください。 レジストリをバックアップ、復元、変更する方法の詳細については、次の資料番号をクリックして、Microsoft サポート技術情報の記事を参照してください。
322756 Windows でレジストリをバックアップおよび復元する方法
現象
多数の I/O 操作を実行し、大量のデータを含む Windows Server ベースのコンピューターでボリューム シャドウ コピー サービスを使用すると、次の現象が発生します。
ボリューム シャドウ コピー サービスを有効にしたディスク リソースを含むクラスター グループのクラスター フェールオーバー時間が長くなります。 また、クラスター ノードのディスク ボリュームは、クラスター のフェールオーバー中にオンラインとオフラインに時間がかかります。 ディスクをオフラインにしてから、同じノードでオンラインにしても、同じ遅延が発生します。
クラスター以外のサーバーの起動には時間がかかります。 サーバー ボリュームでボリューム シャドウ コピー サービスを無効にすると、サーバーは想定どおりに開始されます。
原因
この問題は、ボリューム シャドウ コピー ドライバー (Volsnap.sys) がシャドウ コピー ファイルを管理する方法が原因で発生します。 ディスク ボリュームに多数のシャドウ コピー ファイルが作成されている場合、ボリューム シャドウ コピー ドライバーは、システムがディスク ボリュームをオンラインにするときに、それらのシャドウ コピー ファイルの処理に時間がかかります。
回避策
警告
レジストリ エディタや他の方法を使用してレジストリを変更する際、適切に変更しないと重大な問題を引き起こす可能性があります。 場合によっては、オペレーティング システムの再インストールが必要になります。 こうした問題の修復について、マイクロソフトはいかなる保証もいたしません。 レジストリはユーザー自身の責任において変更してください。
この問題を回避するには、新しいレジストリ キーを作成して、各ディスク ボリュームに作成されるシャドウ コピー ファイルの数を 20 に制限します。
Note
この値は、推奨される開始値にすぎません。 作業環境に適した値を見つけることをお勧めします。
新しいレジストリ キーを作成するには、次の手順に従います。
- [スタート]、[ファイル名を指定して実行] の順にクリックし、「regedit」と入力して、Enter キーを押します。
- 次のレジストリ サブキーを見つけて右クリックします。
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS\Settings
- [ New] をポイントし、[ DWORD 値をクリックします。
- 「MaxShadowCopies 入力して Enter キーを押します。
- MaxShadowCopiesをダブルクリックし、[値のデータ] ボックスに「20」と入力し、[OK] をクリックします。
- レジストリ エディターを終了します。
- コンピューターを再起動します。