SSISDB が AG で構成されている場合、エラー 945 と SQL Server のアップグレードが失敗する
この記事は、データベース アップグレード スクリプトの実行時に Microsoft SQL Server の累積的な更新プログラム (CU) または Service Pack (SP) がエラー コード 945 を報告した場合に発生する問題のトラブルシューティングに役立ちます。
現象
CU または SP を適用すると、セットアップ プログラムは次のエラー メッセージを返します。
データベース エンジンの復旧ハンドルの待機に失敗しました。 考えられる原因については、SQL Server エラー ログを確認してください
さらに、次のエラー エントリが SQL Server エラー ログに記録される場合があります。
Database 'master' is upgrading script 'SSIS_hotfix_install.sql' from level 201331031 to level 201331592.
Error: 945, Severity: 14, State: 2.
Database 'SSISDB' cannot be opened due to inaccessible files or insufficient memory or disk space. See the SQL Server errorlog for details.
Error: 912, Severity: 21, State: 2.
Script level upgrade for database 'master' failed because upgrade step 'SSIS_hotfix_install.sql' encountered error 945, state 2, severity 25. This is a serious error condition which might interfere with regular operation and the database will be taken offline. If the error happened during upgrade of the 'master' database, it will prevent the entire SQL Server instance from starting. Examine the previous errorlog entries for errors, take the appropriate corrective actions and re-start the database so that the script upgrade steps run to completion.
Error: 3417, Severity: 21, State: 3.
Cannot recover the master database. SQL Server is unable to run. Restore master from a full backup, repair it, or rebuild it. For more information about how to rebuild the master database, see SQL Server Books Online.
SQL Server shutdown has been initiated
原因
SQL Server Integration Services カタログ データベース (SSISDB) を Always On 可用性グループ (AG) に追加すると、スクリプトのアップグレードが失敗する可能性があります。 アップグレード プロセスは、シングル ユーザー モードで実行されます。 ただし、可用性データベースはマルチユーザー データベースである必要があります。 そのため、アップグレードのインストール中に、SSISDB を含むすべての可用性データベースがオフラインになり、アップグレードされません。
詳細については、可用性グループの SSISDB の アップグレードを参照してください。
解決方法
この問題を解決するには、次の手順を実行します:
- AG から SSISDB を削除します。
- 各ノードで CU アップグレードを実行します。
- アップグレードが完了したら、SSISDB を AG に復元します。