接続エラー 10054 は、アップグレード後SQL Server発生する可能性があります
Microsoft SQL Serverアップグレード後に、接続エラーが発生します。 このエラーは、SQL Server エージェント サービスのローカル システム アカウントを使用した後でも続行される可能性があります。
現象
エディション (STD) Microsoft SQL Server Standardアップグレードした後、SQL Server エージェントはすぐに開始および停止します。 さらに、次の 1 つ以上のエラー メッセージが表示されます。
SQL Serverは接続を受け入れません (エラー: 10054)。 接続を許可するSQL Serverを待機しています。 操作が試行されました: [スタート] で接続を確認します。
SQLServer エラー: 10054、SSL プロバイダー: 既存の接続がリモート ホストによって強制的に閉じられました。 [SQLSTATE 08001]
SQLServer エラー: 10054、クライアントが接続を確立できない [SQLSTATE 08001]
原因
Microsoft SQL Serverアップグレード後に TLS が無効になり、接続エラーが発生することがあります。 アップグレードのインストール後に TLS プロトコルが無効になっているかどうかを確認します。
解決方法
エラーを解決するには、次の手順に従います。
次のレジストリ エントリを設定して TLS を有効にします。
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS1.0
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS1.1
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS1.2
コンピューターを再起動して、変更が適用されていることを確認します。