Power Automate 埋め込みエクスペリエンスにアクセスするときのサードパーティの Cookie またはポップアップ ブロック エラー
この記事は、Power Automate が他のアプリまたは Web サイト内の埋め込みエクスペリエンスで開始されないようにする一般的な構成の問題を修正するのに役立ちます。
現象
SharePoint、Power Apps 内、またはカスタム SDK 統合を使用して Power Automate の埋め込みインスタンスにアクセスすると、空白の画面が表示されたり、スピナーに画面が表示されたりすることがあります。
原因
これらの問題は、サードパーティの Cookie が Web ブラウザーでブロックされるために発生します。
解決方法
Power Automate では、ブラウザーの機能を使用して、ユーザー ID や基本設定などの一部のデータがローカルに格納されます。 ブラウザーがこのようなローカル データまたは Power Automate によって設定されたサードパーティの Cookie のストレージをブロックすると、問題が発生します。
問題を解決するには、使用しているブラウザーの設定に移動し、サードパーティの Cookie を有効にして、関連サイトが Cookie に対してブロックされていないことを確認します。
Microsoft Edge の手順
オプション 1: すべてのサイトに対してサードパーティの Cookie とローカル データの保存を有効にする
- 設定>Cookie とサイトのアクセス許可を選択します。
- [ 管理] を展開し、Cookie とサイト データを削除します。
- サード パーティの Cookie をブロック設定が無効になっていることを確認します。
- 存在する場合は、Block のサイト固有の Cookie 構成から次のサイトを削除し、終了時にclear をします
https://make.powerautomate.com
https://*.make.powerautomate.com
https://make.*.powerautomate.com
https://login.microsoftonline.com
オプション 2: Power Automate および関連サービスのサード パーティの Cookie とローカル データの保存を許可する例外を作成する
Note
次の手順では、Edge ブラウザーのバージョンが 87 以上である必要があります。
- 設定>Cookie とサイトのアクセス許可を選択します。
- [ 管理] を展開し、Cookie とサイト データを削除します。
- [Allow で Add を選択し、次を追加します。
[*.]powerautomate.com
- [閉じるにClear ブラウズ データを選択します。
- Cookie とその他のサイト データが無効になっていることを確認します。 有効のままにする場合は、代わりに Add を選択し、次を追加します。
[*.]powerautomate.com
Google Chrome の手順
オプション 1: すべてのサイトに対してサードパーティの Cookie とローカル データの保存を有効にする
- Settings>Privacy と security を選択します。
- [ Cookie とその他のサイト データを展開します。
- サードパーティの Cookie のブロックまたは すべての Cookie のブロックが選択されていないことを確認します。
- 存在する場合は、サイト固有の Cookie 構成から、常に Cookie を使用できるサイトから次のサイトを削除しウィンドウが閉じられたときに Cookie をクリアします
https://make.powerautomate.com
https://*.make.powerautomate.com
https://make.*.powerautomate.com
https://login.microsoftonline.com
オプション 2: Power Automate および関連サービスのサード パーティの Cookie とローカル データの保存を許可する例外を作成する
- Settings>Privacy と security を選択します。
- [ Cookie とその他のサイト データを展開します。
- 常に Cookie を使用できるサイトに移動し[追加] を選択して、次を追加します。
[*.]powerautomate.com
- サイトを追加するときは、必ず このサイトでサードパーティの Cookie を含む オプションを選択してください。