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無人デスクトップ フロー実行のセッション作成エラー コードを解決する

この記事では、Microsoft Power Automate で無人デスクトップ フローの実行中に発生する可能性がある SessionCreationErrorSessionCreationErrorWithThirdPartyCredentialProvider エラー コードの背景と考えられる解決策について説明します。

適用対象: Power Automate

現象

意図しないデスクトップ フローの実行SessionCreationErrorまたはSessionCreationErrorWithThirdPartyCredentialProviderエラー コードで失敗する可能性があります。

原因

無人セッションが実行されると、Power Automate はターゲット コンピューターにリモート デスクトップ (RDP) セッションの作成を試みます。 このセッションの作成が失敗した場合は、次のいずれかのエラー コードが表示されることがあります。

SessionCreationErrorWithThirdPartyCredentialProvider

このエラー コードは、サード パーティ製ソフトウェアが Power Automate のマシン上にセッションを作成する機能を妨げているために発生します。 Power Automate では、一部のサード パーティの資格情報プロバイダーはサポートされていません。

解決方法

この問題を解決するには、管理者に連絡して、Power Automate でサポートされていない資格情報プロバイダーをアンインストールしてください。

次のレジストリ キーで、コンピューター上の資格情報プロバイダー (その多くは組み込み) の完全な一覧を確認できます。

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\Credential Providers

各サブキーは、インストールされている資格情報プロバイダーを表します。 次の表に、Power Automate で現在サポートされていない資格情報プロバイダーを示します。 次のレジストリ キーがある場合は、システム管理者と協力して、対応するソフトウェアをアンインストールしてください。

Name サブキー名
SailPoint Technologies デスクトップパスワードリセット 0094A34B-0BF0-4789-8B2D-8339E469D756

SessionCreationError

このエラー コードは、不明な理由でセッションの作成が失敗した場合に発生します。

解決方法

この問題を解決するには、次のようにします。

  • ネットワーク上の別のコンピューターからコンピューターにリモート デスクトップできることを確認します。 Windows Server を使用している場合は、別のアカウントとしてログインするときに、ローカル コンピューター自体から "localhost" にリモート デスクトップを試すことができます。 これらのアクションが失敗した場合は、 General リモート デスクトップ接続のトラブルシューティングを参照してください。
  • ログインに関する法的通知が有効になっている場合は、システム管理者と協力して無効にしてみてください。 法的通知がアクティブ化されているかどうかを確認するには、レジストリ エディターを開き、 Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Systemに移動します。 legalnoticecaptionまたはlegalnoticetextが空でない場合は、システム管理者と協力して法的通知を無効にしてください。
  • ログインに影響を与えたり、リモート デスクトップ接続の作成を妨げたりする可能性のあるサード パーティ製ソフトウェアがインストールされていないことを確認します。
  • ドメイン アカウント (DOMAIN\user) を使用して接続すると、ドメイン コントローラーの接続の問題によってセッションが正しく開かなくなる可能性があります。 システム管理者と協力して、接続ログを確認してください。 Microsoft Entra 参加済みデバイスまたは Entra ハイブリッド参加済みデバイスを使用している場合は、UPN (user@domain.com) を使用してみてください。 UPN を使用できるかどうかを確認するには、 Start>Run に移動し、 dsregcmd /status コマンドを実行します。 Device Stateの下にAzureAdJoined: YESが表示される場合は、接続で指定されたユーザーをuser@domain.com形式に変更してみてください。

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