次の方法で共有


MSEntraMachineAlwaysPromptingForPassword エラーで無人デスクトップ フローの実行が失敗する

この記事では、Microsoft デスクトップ用 Power Automate で無人デスクトップ フローを実行するときに発生するエラーの解決策について説明します。

現象

無人デスクトップ フローの実行は、"MSEntraMachineAlwaysPromptingForPassword" エラー コード (旧称 "AADMachineAlwaysPromptingForPassword") で失敗します。

{
    "error":{
        "code": "MSEntraMachineAlwaysPromptingForPassword",
        "message": "Could not create unattended session with these credentials."  
    }    
}

[run a flow built with with デスクトップ用 Power Automate] ページの [本文] セクションに示されているエラー コードのスクリーンショット。

原因

デスクトップ用 Power Automateは、マシン上で Microsoft Entra ID (旧称 Azure Active Directory) の資格情報を検証できません。 この問題は、通常、コンピューターのグループ ポリシー設定が原因で発生します。

解決方法

この問題を解決するには、コンピューターのグループ ポリシー設定を確認します。

  1. Windows キーを押しながら R を押して、 Run ダイアログを開きます。

  2. gpedit.msc 」と入力し、 Enter キーを押してローカル グループ ポリシー エディターを開きます。

  3. Computer Configuration>Administrative Templates>Windows Components>Remote Desktop Services>Remote Desktop Session Host>Security に移動します。

  4. 接続時にパスワードの入力を求めるプロンプト探します。

    • 設定が有効になっている場合は、IT 部門と協力して、そのマシンのポリシーを無効にします。

      Note

      この値は、 Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services のレジストリにも反映されます。 fPromptForPassword Terminal Services キーの DWORD 値が 1 に設定されている場合は、設定が有効になり、IT 部門と連携して無効にする必要があります (通常、レジストリ値を変更するだけでは、元に戻される可能性があるため、十分ではありません)。

    • Always の接続時にパスワードの入力を求めるメッセージが表示される場合設定が有効になっていないが、エラー コードが表示される場合は、Run ダイアログに「regedit」と入力してレジストリ エディターを開きます。 レジストリ エディターで、 Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp レジストリ キーに移動します。 次に、 fPromptForPassword DWORD を探し、 0 に設定します。 DWORD が存在しない場合は、DWORD を作成し、その値を 0 に設定します。