MSEntraMachineAlwaysPromptingForPassword エラーで無人デスクトップ フローの実行が失敗する
この記事では、Microsoft デスクトップ用 Power Automate で無人デスクトップ フローを実行するときに発生するエラーの解決策について説明します。
現象
無人デスクトップ フローの実行は、"MSEntraMachineAlwaysPromptingForPassword" エラー コード (旧称 "AADMachineAlwaysPromptingForPassword") で失敗します。
{
"error":{
"code": "MSEntraMachineAlwaysPromptingForPassword",
"message": "Could not create unattended session with these credentials."
}
}
原因
デスクトップ用 Power Automateは、マシン上で Microsoft Entra ID (旧称 Azure Active Directory) の資格情報を検証できません。 この問題は、通常、コンピューターのグループ ポリシー設定が原因で発生します。
解決策 1: ユーザー証明書でリモート デスクトップに Microsoft Entra 認証を使用する
この解決にはバージョン 2.50 以降デスクトップ用 Power Automate必要があり、多要素認証 (MFA) 例外がない場合に使用する必要がありますデスクトップ フロー接続アカウントに付与できます。
Power Automate 用に Microsoft Entra 証明書ベースの認証を設定する手順については、「 証明書ベースの認証の構成 (プレビュー)を参照してください。
解決策 2: ユーザー名とパスワードを使用してリモート デスクトップに Microsoft Entra 認証を使用する
この解決には、デスクトップ用 Power Automate バージョン 2.49 以降が必要です。 デスクトップ フロー接続で使用されるアカウントに対して MFA を有効にしていない場合は、代わりにユーザー名とパスワードを使用して Microsoft Entra 認証を設定できます。
管理特権でレジストリ エディター (regedit) を開きます。 次のレジストリ パスに移動し、
UseRdsAadAuthentication
という名前の新しい DWORD-32 値を作成し、UseRdsAadAuthentication
の値を 1 に設定します。レジストリ パス レジストリ キー DWORD-32 値 Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Power Automate Desktop\Service UseRdsAadAuthentication
1 Power Automate サービスを再起動します。
ユーザー名とパスワードの資格情報で Microsoft Entra ID 接続を使用します。 このアカウントには MFA 例外が必要であることに注意してください。
解決策 3: fPromptForPassword を無効にする
この問題を解決するには、コンピューターのグループ ポリシー設定を確認します。
Windows キーを押しながら R を押して、 Run ダイアログを開きます。
「 gpedit.msc 」と入力し、 Enter キーを押してローカル グループ ポリシー エディターを開きます。
Computer Configuration>Administrative Templates>Windows Components>Remote Desktop Services>Remote Desktop Session Host>Security に移動します。
接続時にパスワードの入力を求めるプロンプト探します。
設定が有効になっている場合は、IT 部門と協力して、そのマシンのポリシーを無効にします。
Note
この値は、 Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services のレジストリにも反映されます。 fPromptForPasswordTerminal Services キーの DWORD 値が 1 に設定されている場合は、設定が有効になり、IT 部門と連携して無効にする必要があります (通常、レジストリ値を変更するだけでは、元に戻される可能性があるため、十分ではありません)。
Always の接続時にパスワードの入力を求めるメッセージが表示される場合設定が有効になっていないが、エラー コードが表示される場合は、Run ダイアログに「regedit」と入力してレジストリ エディターを開きます。 レジストリ エディターで、 Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp レジストリ キーに移動します。 次に、 fPromptForPassword DWORD を探し、 0 に設定します。 DWORD が存在しない場合は、DWORD を作成し、その値を 0 に設定します。