Intune に登録されている ADE デバイス上の会社のリソースにアクセスすることはできません
この記事では、Apple Automated Device Enrollment (ADE) デバイスで会社のリソースにアクセスできない場合に発生するエラーを解決する 2 つの方法について説明します。
現象
Microsoft Intune に登録され、条件付きアクセス ポリシーが適用されている ADE デバイスがある。 デバイス上のクラウド アプリにアクセスしようとすると、次のエラー メッセージが表示されます。
サインインは成功しましたが、管理者はこのリソースにアクセスするためにデバイスを <CompanyName> で管理する必要があります。
原因
この問題は、以下の条件に該当する場合に発生します。
- 登録プロファイルには、 Authentication メソッド Setup Assistant に設定されています。
- ポータル サイト アプリは ADE デバイスにデプロイされていません。
- 条件付きアクセス ポリシーを適用するには、ポータル サイト アプリが必要です。
解決策 1
Authentication メソッドを登録プロファイルにポータル サイトするように設定します。 これを行うには、次の手順を実行します。
Microsoft Intune 管理センターにサインインしDevices>iOS/iPad>iOS/iPad 登録>登録プログラム トークンを選択します。
トークンを選択 Profilesを選択し、影響を受けるデバイスに割り当てられている登録プロファイルを選択します。
Authentication メソッド一覧で、ポータル サイトを選択します。
Note
認証方法を Setup Assistant から ポータル サイト に変更すると、Intune は iOS セットアップ アシスタントを介してユーザー認証をスキップし、代わりに先進認証を使用します。 これにより、ユーザーは Microsoft Entra 多要素認証 (MFA) を使用できます。 このメソッドは、Apple ADE 登録をブロックせずに適用できます。
解決策 2
ポータル サイト アプリをデバイスに展開します。 これを行うには、「 管理対象 iOS/iPadOS デバイス用のアプリ構成ポリシーを追加するの手順に従います。