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エラー AADSTS750054 - SAML リダイレクト バインディング用の HTTP 要求に、SAMLRequest または SAMLResponse がクエリ文字列のパラメーターとして指定されている必要がある

この記事では、Microsoft Entra ID と統合された SAML ベースのシングル サインオン (SSO) 構成アプリにサインインしようとすると、"エラー AADSTS750054 - SAMLRequest または SAMLResponse は、SAML リダイレクト バインドの HTTP 要求にクエリ文字列パラメーターとして存在する必要があります" というエラー メッセージが表示される問題について説明します。

現象

SAML ベースの SSO を使用して ID 管理に Microsoft Entra ID を使用するように設定されているアプリケーションにサインインしようとすると、エラー AADSTS750054 が表示されます。

原因

Microsoft Entra ID によって、HTTP 要求の URL パラメーター内から SAML 要求が識別されませんでした。 これは、SAML 要求を Microsoft Entra ID に送信するときに、アプリケーションが HTTP リダイレクト バインドを使用していない場合に発生する可能性があります。

解決方法

アプリケーションが、HTTP リダイレクト バインディングを使用して、エンコードされて location ヘッダーに含められた SAML 要求を送信する必要があります。 これの実装方法の詳細については、SAML プロトコルの仕様書の HTTP リダイレクト バインディングに関するセクションを参照してください。

ほとんどの場合、エラーは次のいずれかの問題が原因です。

  1. アプリケーション側でシングル サインオンが有効になっていることを確認します。
  2. アプリケーションは、サービス プロバイダーによって開始されるシングル サインオン (SP Initiated SSO とも呼ばれます) をサポートする必要があります。 ID プロバイダーによって開始されるシングル サインオンのみをサポートするアプリケーションのサインイン URL を入力すると、SAML 応答なしでアプリケーションからバウンスバックする可能性があります。
  3. サインオン URL が正しく構成されていることを確認します。

Microsoft Entra 管理センターでのテスト SSO 関数の使用

Microsoft Entra 管理センターは、SAML 構成エラーのトラブルシューティングに役立ちます。

Microsoft Entra 管理センターでの SSO 機能のテストのスクリーンショット。

  1. Microsoft Entra 管理センターで、 Enterprise Applications に移動し トラブルシューティングが必要なアプリケーションをクリックします。
  2. 左側のナビゲーション メニューを使用して Single のサインオン ページに移動します
  3. [このアプリケーションのテスト をクリックして SSO のテスト機能を使用します。
  4. 受け取ったエラーをコピーして Resolving Errors セクションに貼り付け、 Get 解決ガイダンスをクリックします
  5. 手順に従ってエラーのトラブルシューティングを行います AADSTS750054

その他の情報

Active Directory 認証と承認のエラー コードの完全な一覧については、「 Microsoft Entra の認証と承認のエラー コード」を参照してください。

お問い合わせはこちらから

質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。