エラー AADSTS650056 - アプリケーションの構成が正しくない
この記事では、Microsoft Entra ID と統合されている SAML ベースのシングル サインオン (SSO) 構成済みアプリにサインインしようとすると、次のエラー メッセージが表示される問題について説明します。
エラー AADSTS650056 - アプリケーションの構成が正しくありません。 この場合は、次のいずれかの原因が考えられます。クライアントが、クライアントのアプリケーションの登録で要求されたアクセス許可に '{name}' のアクセス許可を記載していません。 あるいは、管理者がテナントで同意していません。 あるいは、要求のアプリケーション識別子を調べて、構成したクライアント アプリケーション識別子に一致することを確認してください。 または、要求の証明書を確認して、有効であることを確認します。 構成を修正するか、テナントの代わりに同意するように管理者に連絡してください。 クライアント アプリ ID: {id}。 構成を修正するか、テナントの代わりに同意するように管理者に連絡してください。
現象
SAML ベースの SSO を使用して ID 管理に Microsoft Entra ID を使用するように設定されているアプリケーションにサインインしようとすると、エラー AADSTS650056
が表示されます。
原因
SAML 要求でアプリケーションから Microsoft Entra ID に送信される Issuer
属性が、Microsoft Entra ID でアプリケーション用に構成された識別子の値と一致しません。
解決方法
SAML 要求の Issuer
属性が、Microsoft Entra ID で構成された識別子の値と一致していることを確認します。
[識別子] テキスト ボックス内の値が、エラーで表示されている識別子の値に一致していることを確認します。
Issuer 属性の詳細については、「 Single Sign-On SAML protocol」を参照してください。
その他の情報
Active Directory の認証と承認のエラー コードの完全な一覧については、「 Microsoft Entra の認証と承認のエラー コードを参照してください。
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