次の方法で共有


エラー AADSTS50105 - サインインしているユーザー にアプリケーションのロールが割り当てられていない

この記事では、Microsoft Entra ID を使用したフェデレーション認証中に発生するAADSTS50105 エラーの解決策について説明します。

Note

この記事は役に立ちましたか? あなたの入力は私たちにとって重要です。 このページの Feedback ボタンを使用して、この記事がどれだけうまく機能したか、または改善方法をお知らせください。

現象

SAML ベースのシングル サインオン (SSO) を使用して ID 管理に Microsoft Entra ID を使用するように設定されているアプリケーションにサインインしようとすると、次のエラー メッセージが表示されます。

エラー AADSTS50105 - サインインしているユーザーがアプリケーションのロールに割り当てされていません。

原因

このユーザーは、Microsoft Entra ID 内のアプリケーションへのアクセスを許可されていません。 ユーザーは、アプリケーションに割り当てられているグループに属しているか、直接割り当てられている必要があります。

Note

入れ子になったグループはサポートされていないため、グループをアプリケーションに直接割り当てる必要があります。

解決方法

1 人以上のユーザーをアプリケーションに直接割り当てるには、アプリへのユーザーの割り当てについてのクイックスタートに関するページを参照してください。

その他の情報

Active Directory 認証と承認のエラー コードの完全な一覧については、「 Microsoft Entra の認証と承認のエラー コードを参照してください。

お問い合わせはこちらから

質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。