エラー AADSTS50105 - サインインしているユーザー にアプリケーションのロールが割り当てられていない
この記事では、Microsoft Entra ID を使用したフェデレーション認証中に発生するAADSTS50105 エラーの解決策について説明します。
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現象
SAML ベースのシングル サインオン (SSO) を使用して ID 管理に Microsoft Entra ID を使用するように設定されているアプリケーションにサインインしようとすると、次のエラー メッセージが表示されます。
エラー AADSTS50105 - サインインしているユーザーがアプリケーションのロールに割り当てされていません。
原因
このユーザーは、Microsoft Entra ID 内のアプリケーションへのアクセスを許可されていません。 ユーザーは、アプリケーションに割り当てられているグループに属しているか、直接割り当てられている必要があります。
Note
入れ子になったグループはサポートされていないため、グループをアプリケーションに直接割り当てる必要があります。
解決方法
1 人以上のユーザーをアプリケーションに直接割り当てるには、アプリへのユーザーの割り当てについてのクイックスタートに関するページを参照してください。
その他の情報
Active Directory 認証と承認のエラー コードの完全な一覧については、「 Microsoft Entra の認証と承認のエラー コードを参照してください。
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