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エラー AADSTS50003 - 署名キーが構成されていない

この記事では、Microsoft Entra ID と統合された SAML ベースのシングル サインオン (SSO) 構成済みアプリにサインインしようとすると、"エラー AADSTS50003 - 署名キーが構成されていません" というエラー メッセージが表示される問題について説明します。

現象

SAML ベースの SSO を使用して ID 管理に Microsoft Entra ID を使用するように設定されているアプリケーションにサインインしようとすると、エラー AADSTS50003 が表示されます。

原因

アプリケーション オブジェクトが破損しており、Microsoft Entra ID がアプリケーション用に構成された証明書を認識しません。

解決方法

証明書を削除して新しい証明書を作成するには、次の手順に従ってください。

  1. SAML ベースの SSO 構成画面の [SAML 署名証明書] セクションで、[新しい証明書の作成] を選択します。
  2. 有効期限を選択し、[保存] をクリックします。
  3. [新しい証明書をアクティブにする] をオンにして、アクティブな証明書をオーバーライドします。 次に、ウィンドウの上部にある [保存] をクリックし、ロールオーバー証明書をアクティブにすることを受け入れます。
  4. [SAML 署名証明書] セクションで、[削除] をクリックして、未使用の証明書を削除します。

その他の情報

Active Directory 認証と承認のエラー コードの完全な一覧については、「 Microsoft Entra の認証と承認のエラー コード」を参照してください。

お問い合わせはこちらから

質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。