次の方法で共有


Field Service Mobile アプリ モジュールのナビゲーションに設定領域がありません

この記事では、Field Service Mobile アプリ モジュールのナビゲーション ウィンドウで Settings 領域を有効にするための解決策について説明します。

現象

Field Service Mobile アプリ モジュールには Settings 領域が表示されないため、管理者は新しいエクスペリエンス 実現できません

原因

新しいモバイル エクスペリエンス Settings トグルは、既定の Field Service Mobile アプリ モジュールに付属する新しいナビゲーション領域で使用できます。 この領域にアクセスするには、FieldServiceSetting エンティティに対するwriteアクセス許可が必要です。 システム管理者やフィールド サービス管理者などの既定のセキュリティ ロールには、そのアクセス許可が自動的に付与されます。 ただし、すぐに使用できる Field Service Mobile アプリ モジュールのサイトマップでカスタマイズを行うと、場合によっては Settings 領域が表示されないことがあります。

解決方法

まず、サイトマップ領域が既定の Field Service Mobile ソリューション レイヤーに存在するが、カスタマイズ レイヤーがそれを上書きするかどうかを確認します。

  1. Power Apps にサインインします。
  2. 環境に変更し、 fieldservice_patch_update ソリューションを開きます。
  3. fieldservice_patch_update ソリューション中の msdyn_FSMobileSettingsArea コンポーネントの ソリューション レイヤーを見る

サイトマップ上のカスタマイズ レイヤーが上部にあり、この領域をオーバーライドしている場合は、次のいずれかのオプションを使用して Settings 領域を有効にします。

オプション 1: サイトマップのカスタマイズ レイヤーを削除し、もう一度手動でカスタマイズする

  1. 管理されていないカスタマイズ レイヤーを削除する
  2. サイトマップのカスタマイズ を再度適用します。

オプション 2: Settings 領域を手動で追加し、サイトマップに切り替える

  1. app デザイナーでカスタマイズしたアプリを開きます

  2. エリアを有効にして、Field Service Mobile 設定用の新しいエリア を作成します。

  3. モバイル設定の新しいグループ を作成します。

  4. グループに新規ページを追加します。 コンテンツ タイプ URL を選択します。

  5. URL 入力として /main.aspx?etn=msdyn_fieldservicesetting&pagetype=entityrecord&id=e49c6117-5065-423f-8ab5-fcacfda85a04&formid=ee334fea-0cd5-471c-bb30-829f4511a59f を使用します。

  6. 新機能のサブエリアを追加します。

    1. ID 配下で、詳細設定権限 を展開します。
    2. テーブル特権の追加>フィールド サービス設定を選択し、Write 特権のみを選択します。
  7. [ Apply>保存して発行を選択します。