次の方法で共有


Dynamics 365 Field Service でエラー メッセージに表示されたユーザーを特定できない

この記事では、ユーザー ID を含む Field Service エラー メッセージに表示されるユーザーを特定できない問題を解決します。

現象

Microsoft Dynamics 365 Field Service では、Dataverse のユーザー ID を含むエラー メッセージが表示されますが、ユーザーを識別することはできません。

原因

ユーザーに関連する Dataverse エラー メッセージには、 Microsoft Entra ID ユーザー ID ではなく Dynamics 365 Field Service ユーザー ID が表示されます。 さらに、Dataverse ユーザー ID は環境に固有です。

解決方法

Note

手順を実行するには、Dynamics 365 Field Service の管理者権限が必要です。

ユーザーを識別するには、次の手順に従います。

  1. Field Service アプリで、フィールド サービス環境を選択します。

  2. 左下隅にある Settings>Users を選択します。

  3. ユーザーを選択すると、URL の末尾に systemuser&id が表示されます。

    systemuser> が強調表示されている [Field Service Settings Users] ページを示すスクリーンショット。

  4. ID 番号をエラー メッセージに表示されている ID に置き換え、 Enter キーを押します。 この ID に関連付けられているユーザーのアカウントが表示されます。