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レコードの自動作成と更新ルールに関する一般的な構成の問題のトラブルシューティング

この記事では、レコードの作成が失敗したりスキップされたりする可能性があるため、レコードの自動作成と更新ルールを使用する一般的な構成エラー シナリオの解決策について説明します。

シナリオ 1

サンプル: レコードの自動作成と更新ルールの構成

  • [ 不明な送信者の連絡先の作成 ] オプションを選択する必要があります。
  • 条件条件を [任意の受信メール] に設定します。
  • ケースを作成するアクションを追加し、[ プロパティの表示] を選択し、ビジネス ユース ケースごとにケース フィールドを設定します。

エラー 1 - "ケースに顧客が見つかりません"

[CASE DETAILS]\(ケースの詳細\) セクションの [Customer]\(顧客\) フィールドで、Senders Account (Email) の値が次のように設定されます。

[顧客] フィールドで Senders Account (Email) の値がどのように設定されているかを示すスクリーンショット。

この設定により、システム ジョブで次のエラーが発生します。

ケースに顧客がありません。

ケースに顧客が見つからないことを示すエラーの詳細を示すスクリーンショット。

エラー 1 の解決策

この問題を解決するには、[顧客] フィールドを空白のままにするか、{Sender(Email)} に設定します。 これにより、不明な送信者の連絡先が自動的に作成され、ケースにリンクされます。

エラー 2 - "エラーが発生しました"

[顧客] フィールドは {Senders Account(Email)} に設定され、[連絡先] フィールドは {Sender(Email)} に設定されます。

[顧客] フィールドと [連絡先] フィールドに設定された値を示すスクリーンショット。

この設定により、システム ジョブで次のエラーが発生します。

エラーが発生しました。 このアクションをもう一度お試しください。 問題が解決しない場合は、ソリューションの Microsoft Dynamics 365 Communityをチェックするか、organizationの Microsoft Dynamics 365 管理者にお問い合わせください。 最後に、Microsoft サポートにお問い合わせください。

[顧客] フィールドに設定された値が原因で発生するエラーの詳細を示すスクリーンショット。

エラー 2 の解決

この問題を解決するには、[顧客] フィールドを空白のままにするか、{Sender(Email)} に設定します。 これにより、不明な送信者の連絡先が自動的に作成され、ケースにリンクされます。

エラー 3 - "指定した連絡先は、顧客フィールドで指定された連絡先に属していません"

[顧客] フィールドと [連絡先] フィールドは {Sender(Email)} に設定されます。

[顧客] フィールドと [連絡先] フィールドに設定された値を示すスクリーンショット。

この設定により、システム ジョブで次のエラーが発生します。

指定した連絡先は、顧客フィールドで指定された連絡先に属していません。 連絡先フィールドから値を削除するか、選択した顧客に関連付けられている連絡先を選択してから、もう一度やり直してください。

指定した連絡先が [顧客] フィールドで指定された連絡先に属していないことを示すエラーの詳細を示すスクリーンショット。

エラー 3 の解決方法

この問題を解決するには、[連絡先] フィールドを空白のままにし、[顧客] フィールドを空白または {Sender(Email)} に設定します

検証手順

次の表に示す構成と検証の手順を検証して、問題のメイン原因を理解し、解決する必要があります。

サービス管理でのレコードの自動作成と更新ルールのオプション として選択されている場合 検証手順 結果
顧客に有効な権利が存在する場合にケースを作成する はい 顧客に対してアクティブな権利が存在することを検証します。 有効なアクティブな権利は、次のように評価されます。
- 電子メールの送信者が親アカウントとの連絡先である場合、顧客サービスDynamics 365、連絡先の親アカウントに有効な権利があり、その連絡先が権利
[連絡先] セクションに一覧表示されている場合、または
- 連絡先セクションが空の場合 (顧客のすべての連絡先に権利が適用されることを意味します)
ケースが作成されます。
不明な送信者から送信されたメールからケースを作成する はい 不明な送信者からの受信メールの場合 - ケースが作成されます。
- 不明な送信者の連絡先も作成されます。
はい 非アクティブなアカウントまたは連絡先のメール アドレスを含む受信メールの場合 - ケースが作成されます。
- 非アクティブなアカウントまたは連絡先がアクティブ化されます。
不要 アクティブなアカウントまたは連絡先のメール アドレスを含む受信メールの場合 ケースが作成されます。
不要 アカウントまたは連絡先以外のレコードの種類で送信される受信メールの場合 ケースは作成されません。
不要 非アクティブなアカウントまたは連絡先のメール アドレスを含む受信メールの場合 ケースは作成されません。
解決されたケースに関連付けられているアクティビティのケースを作成する はい 解決されたケースに関連する受信メールの場合 ケースが作成されます。
はい アクティブなケースに関連する受信メールの場合 ケースは作成されません。

シナリオ 2 - レガシ エクスペリエンスで {Regarding(Email)} を使用しても、フロー内の正しいデータが提供されない

Customer Service の従来の "レコードの自動作成と更新ルール" 項目で、電子メールを送信するエンティティ (連絡先またはアカウント) を検索するには、Sender (Email) ポリモーフィックルックアップを使用できます。これにより、適切なエンティティが自動的にフェッチされ、エンティティの名前が表示されます。 ポリモーフィックルックアップは、ルックアップのターゲットが複数の種類のエンティティであるルックアップです。 たとえば、連絡先またはアカウントを指すことができます。 ただし、最新の "レコードの自動作成と更新ルール" では、この自動表示はサポートされていないため、取得するエンティティの種類とそのエンティティから表示するフィールドを指定する必要があります。

原因

フロー式は前のフロー ステップのペイロードのいずれかからデータ値を参照するため、フローではレガシ ワークフローのような {Regarding(Email)} 値は使用されません。 たとえば、フローの開始時に {Regarding(Email)} の値が空の場合、{Regarding(Email)} のトリガー ステップ ペイロードの値は空のままです。 ケースの作成後に {Regarding(Email)} 値が更新された場合でも、電子メール レコード データは更新されますが、フロー内のペイロードは更新されません。 そのため、ペイロードの値が後続のフロー ステップで参照されると、空のままです。

解決方法

レガシ ルール項目で {Regarding(Email)} 値を使用する場合は、移行されたフローを手動で更新して "インシデント ID" または "OData ID" を使用する必要があります。エンティティ参照または参照を必要とするフィールドには、"OData Id" を使用します。 GUID を必要とするフィールドには、大文字と小文字の一意の識別子を使用します。

シナリオ 3 - レガシから最新の "レコードの自動作成と更新ルール" への移行中に、ルックアップ以外のフィールドにポリモーフィックな参照をレンダリングする際の問題

Sender などのポリモーフィックな検索を使用する従来の "レコードの自動作成と更新ルール" 項目は、テキスト フィールドに割り当てられると無効な参照になります。

Customer Service の従来の "レコードの自動作成と更新ルール" 項目で、電子メールを送信したエンティティ (連絡先またはアカウント) を検索するには、Sender (Email) ポリモーフィックルックアップを使用できます。これにより、適切なエンティティが自動的にフェッチされ、エンティティの名前が表示されます。 ポリモーフィックルックアップは、ルックアップのターゲットが複数の種類のエンティティであるルックアップです。 たとえば、連絡先またはアカウントを指すことができます。 ただし、最新の "レコードの自動作成と更新ルール" では、この自動表示はサポートされていません。 そのため、取得するエンティティの種類と、そのエンティティから表示するフィールドを指定する必要があります。

原因

従来の "レコードの自動作成と更新ルール" で使用されるクラシック ワークフローの動作には、多くの非表示の動作があります。 たとえば、エンティティの種類を自動的に決定し、パラメーターが文字列で使用されている場合は表示名としてフィールドをフェッチしますが、ルックアップ フィールドに割り当てられている場合は ID を返します。 "レコードの自動作成と更新ルール" がレガシから最新のワークフローに変換するときに使用するプラットフォーム移行コードでは、必要な手順とフィールドは追加されません。

解決方法

この問題を解決するには、

  • 参照を特定の型に更新します。
  • 目的のテキストを含む受信エンティティで別のフィールドを使用します。